Support » Plugin: W3 Total Cache » Failed to set referrer policy error

  • Resolved cdkuhn


    Not sure if it was the latest update or not, but I just noticed this error popping up. When I deactivate W3 Total Cache, it goes away. I have tried uninstalling and reinstalling the plugin with same results. I have searched and found no fix, only descriptions of the error.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 16 through 25 (of 25 total)
  • @gidomanders great and ty for your fast reply!

    BG Bruno


    @heitor_tito thx it helped šŸ™‚

    I tried every way to fix this issue. After 5-45 mins, my homepage usually gets this issue, doesn’t matter how I set Browser Cache.

    Does anyone have the solution?

    • This reply was modified 10 months, 4 weeks ago by  maglobalcrown.

    W3TC->Browser Cache->Referrer Policy allows you to supply a directive now. Simply update that to no-referrer-when-downgrade or origin. You can read up on it here

    Updating the htaccess file wont help as this will get overwritten by this setting in W3TC

    @mayerwin Thank you ! This worked for me.

    Patrick Toulze


    I try no-referrer-when-downgrade and origin

    Whenever I reload the front page = 403

    Deactivate the plugin – Everything fine.

    This mean
    1ā€” that my client site was not accessible for a while
    2ā€” An imbecile on my Hosting service uninstall a plugin that, he think was the problem, this will cost me hours to reinstall an setup.

    Iā€™m not Happy.

    Plugin Support Marko Vasiljevic


    Hello @patrick-toulze,

    If you disable Referrer Policy does the issue persist?
    Can you please share your .htaccess when origin or no-referrer-when-downgrade is selected?

    This case is marked as Resolved, but I still find some sites facing this issue.
    Does it mean the issue can be resolved with a workaround?
    Or, has the plugin been revised to check against the wrong value of referrer policy directive and force the default value of no-referrer-when-downgrade?

    The solution given by @thurefransen solved my problem. Thanks.!

    I bumped into this when was making W3C configuration on shared hosting. My advise is to save this header, but use checkbox beneath – my preference is “Same Origin”

Viewing 10 replies - 16 through 25 (of 25 total)
  • You must be logged in to reply to this topic.