Support » Plugin: W3 Total Cache » Failed to set referrer policy error

  • Resolved cdkuhn

    (@cdkuhn)


    Not sure if it was the latest update or not, but I just noticed this error popping up. When I deactivate W3 Total Cache, it goes away. I have tried uninstalling and reinstalling the plugin with same results. I have searched and found no fix, only descriptions of the error.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 24 total)
  • Ramanan

    (@superpoincare)

    Me too.

    For now in the browser cache tab, check the new additions and uncheck referrer policy.

    Fist Full of Crisco

    (@fistfullofcrisco)

    It seems to work fine for me — i dont get this error.

    1. What is the exact error message and where is it showing? In your error_logs or admin page?

    2 Are you using nginx or apache/litespeed?

    3. What is your referrer policy directive set to?

    4. Browser (Chrome, Firefox, … )?

    My hope is to get the same error to pinpoint the problem. Should be an easy fix.

    Fist Full of Crisco

    (@fistfullofcrisco)

    Just a heads up… was searching around for this error message and discovered this possible solution. It doesn’t look like it is a W3TC problem:

    Just in case if you are here but your referrer policy looks fine but your URL page contains google-ad-words or something social, then ad-blocker might be the culprit. try disabling it.

    Some other advice…it could be an incompatibility with your browser.

    Chrome (desktop/mobile): need at least v61 for full support (Min: v56).
    Firefox (desktop/mobile): need at least v52 for full support (Min: v50).
    Internet Explorer/ Microsoft Edge + mobile: Not supported at all.
    Safari (desktop and mobile): Not supported at all.
    Opera (desktop and mobile): need at least v48
    Samsung Internet Browser: basic support in v6.0

    I tested w3tc’s Referrer-Policy setting in both the latest Chrome and Firefox. Both work perfectly for every directive (and with ADB+ enabled ;P ).

    microonline

    (@microonline)

    The solution is what it says: Ramanan.

    There is a new option that is activated by default and produces this error, deactivate it and work.

    Thanks Ramanan.

    josmatic

    (@josmatic)

    Ramanan – Thank you!!!

    mayerwin

    (@mayerwin)

    I am having the same issue but not seeing any “referrer policy” option in the browser cache tab. Which version of the plugin are you using? Mine is 0.9.7 (community).

    There is only “Reduce server load and decrease response time by using the cache available in site visitor’s web browser.

    Browser Cache: Enable
    Enable HTTP compression and add headers to reduce server load and decrease file load time.”

    Heitor_tito

    (@heitor_tito)

    for me, the option: Referrer Policy uncheck in Menu Browser Cache solved the problem, according to Ramanan.

    thure.fransen

    (@thurefransen)

    Go into your .htaccess file and change the following:

    Header set Referrer-Policy ""

    to

    Header set Referrer-Policy "origin"

    That should fix the issue.

    The reason is more than likely because you don’t have correct permissions on your .htaccess file that allows w3tc to make the changes it needs to…

    mayerwin

    (@mayerwin)

    Found it! I had to go to the left menu “Browser Cache” entry (/wp-admin/admin.php?page=w3tc_browsercache), not the “General Settings” (/admin.php?page=w3tc_general). There, I set the Referrer-Policy to “no-referrer-when-downgrade” which is supposed to be the default.

    I got the same error on one of our good old sites.
    Failed to set referrer policy: The value ” is not one of…
    So, it seems that, depending on from which version to which version the plugin is updated, the value for the new Referrer Policy option is set to an empty string that causes this error on Chrome.

    Plugin Support gidomanders

    (@gidomanders)

    We are aware of the issue having Referrer Policy set to “” instead of no-referrer-when-downgrade after upgrading the plugin and we’re working on a solution.

    Thankyou thure.fransen

    That’s the only thing that worked for me!

    thank you thure.fransen – solved!

    @thurefransen well problem came back even after adding at .htaccess file the value of Header set Referrer-Policy to “origin” – I suppose I have to disable the default option and see how it goes..

    • This reply was modified 9 months, 3 weeks ago by  abiox.
    Plugin Support gidomanders

    (@gidomanders)

    @abiox You can set the Referer Policy in Performance => Browser Cache. The default value became “” in the last update, but the actual default should be “no-referrer-when-downgrade”. You can change it yourself for now, in the next update we have fixed this issue.

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.