Support » Plugin: Yoast SEO » Failed to retrieve your apps from Facebook.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Estou com o mesmo problema.

    the same problem. I can post any aditional info if it will help to solv issue

    The same issue, here.

    If any of you would be willing to share the response url with me, that would really help to solve this.

    If you prefer to not share this here, you can mail it to me @adviesenzo dot nl. **DO NOT USE THIS EMAIL FOR ANYTHING ELSE**

    I believe I’ve fixed this now. The fix will be included in the next release (v1.5.2.3).

    I’d still be interested to see some more sample urls to test the fix.

    Same issue. LoL is there no way for us, to you know, just enter the API & Secret by hand without granting Yoast direct access to our Facebook? Seems a bit intrusive, let me explain why;

    Users of this APP, after you have achieved desired usability, go to:

    Find Yoast. You’ll find:
    “WordPress SEO by Yoast may login as any of your ## Pages”

    It claims all it needs access for is the API, nothing else. So, since it has the API, just delete the app, otherwise your granting Yoast access to control your pages. While I’m sure the plugin is trustworthy, it can’t hurt to bolster your security – many sell permissions for Likes etc.

    Wouldn’t be pointing out the intrusion if the plugin worked as intended & I didn’t need to search the topic. I appreciate the simplicity for the intro user.

    Give us manual control. Look forward to the fix.

    @nicholasdesuza I think you make a valid comment about the access permissions and have opened an issue on GitHub to investigate this. No promises though.



    @jrf I’ve downlaoded the latest version of the plugin (Version and I’m having this problem also. I works fine for one of my sites but basically the page just refreshes on the other one when trying to add the facebook apps. I’d be happy to email you the response URL but I’m not sure what email to send it to. Thanks.

    @jrf I see, thanks for the re-post.

    Really manual control would resolve the issue for most, I’m not sure what level of control is really necessary for retrieving API. I imagine Yoast is hitting a security issue accessing actual applications — which brings up the next question;

    Why Access my Pages when my desired Open Graph Trackers are in my Applications? I clicked “Use a Facebook App as Admin”, not page, user, or profile.

    Need to make a big publish tomorrow, probably just code it in by hand. Although, the single intrusion suggests other salable information leaks in the plugin. Just speculation.

    And to correct myself; this is NOT an “intrusion” if you click “Allow” on the Facebook popup. I usually click “Cancel” or similar as most should around unfamiliar applications — but in this case I allowed the plugin for the sake of getting the Open Graph to work, which it did not.

    So it’s not an intrusion, although it’s requesting access to control and giving nothing in return. I love Yoast, use it for most my SEO, just wish this feature worked and didn’t perform a sketchy action instead of doing what it said it would. haha

    @paul – anything at the domain I mentioned should work. I look forward to seeing the URL.

    @NicolasDeSuza – you may want to add those last comments to the thread on GitHub so the devs will know this when they look into it.



    @jrf – I managed to fix the my problem by simply exporting the plugin settings and then importing them again. I was then able to connect to my available Facebook apps. Maybe this could help others too.

    I have the same problem , i can not get it to work.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Failed to retrieve your apps from Facebook.’ is closed to new replies.