Support » Fixing WordPress » Failed to open stream – wp-settings.php on line 118

  • Hello, I’ve done a search about this, but couldn’t find anything related to my exact problem.

    It all happened overnight, and I’m a little puzzled. I have a few WP blogs (successfully upgraded to 2.3.3 some time ago) hosted on the same website, on different DBs and subdomains, and here is the error message I get when I try to access them now (same message on every blog, only with a different address each time, of course):

    Warning: main(/home/paradygm/public_html/blog/wp-includes/functions.php) [function.main]: failed to open stream: No such file or directory in /home/paradygm/public_html/blog/wp-settings.php on line 118

    Warning: main(/home/paradygm/public_html/blog/wp-includes/functions.php) [function.main]: failed to open stream: No such file or directory in /home/paradygm/public_html/blog/wp-settings.php on line 118

    Fatal error: main() [function.require]: Failed opening required ‘/home/paradygm/public_html/blog/wp-includes/functions.php’ (include_path=’.:/usr/local/lib/php-4.4.7/lib/php’) in /home/paradygm/public_html/blog/wp-settings.php on line 118

    What puzzles me is that this error occurred overnight. And when I say “I didn’t touch anything”, I mean it: I didn’t change the theme nor added any plugin, nor even post anything on them in the past 24 hours before I noticed the problem. I didn’t upgrade either, since I had done it a few weeks ago, and everything had gone well, with no problem at all in the meantime. And I can’t access wp-admin.

    I’ve currently filed a ticket with my host support service, but until they answer me, I’d like to know if others have run into this. I thought my host might have changed their version of PHP or something overnight, so I tried to perform a new 2.3.3 install on the same host, but it went well (besides, I had also performed a clean 2.3.3 install of one of the concerned blogs a few weeks ago, with the same files), so now I really wonder where this could be coming from.

    Thank you,


Viewing 5 replies - 1 through 5 (of 5 total)
  • Wonder if they changed or moved your MySQL server?

    Thanks for the suggestion, I’ve updated my ticket there with it. If they did something, whatever it was, I hope they can fix it, then.

    Would such a move/change concern only existing WP 2.3.3 installs, or previous versions as well? (I still have a WP 2.3.1 install on this very host as well, and after checking again and again, that one works perfectly well. Only the two 2.3.3 installs are currently giving me problems.)

    Well that error is having a problem including your wp-includes/functions.php file so normally I would suggest reuploading at least that file but for that to happen on two different blogs is weird. That could also be a sign of a problem with your theme–guess you could delete your theme files (after backing up the theme files) and WordPress should then try to use the WordPress Default theme.

    Did your host change PHP versions?

    I’m upping this post because I think this might be of interest to someone else, in case they’d run into the same problem.

    I’ve managed to resolve the issue: the functions.php file had simply disappeared. I don’t know how come, I didn’t move/deleted it myself, so I have no clue as to why it happened. Reuploading the original functions.php file from the WP 2.3.3 install package solved the problem.

    However, I’ve just noticed the very same issue happening again. Last week, it was also on a Tuesday, so I wonder if there’s a pattern here. For whomever might be concerned:
    – My blogs are hosted by Ipowerweb.
    – Their support told me that they’re currently experiencing MySQL problems due to platform migration (I don’t know if this could be linked to disappearing files, but whatever).
    – It has only happened with WP 2.3.3 install — WP 3.2.1 (which I still have on a couple of blogs, I know, bad, bad) hasn’t budged.

    Today as well, I resolved the issue the exact same way, by reuploading functions.php.

    Anyway, thanks for the help! I’ll also try to inquire some more as to why such a thing happened. In the meantime, maybe this will be useful to someone else.

    Same thing has happened to me now twice and I am also hosted on IPower (was scheduled to be upgraded to the new server / package on 3/27 but it hasn’t happened yet. I’ve also upgraded to WordPress 2.5 and it just happened to that too. Seems like an IPower problem when they attempt to upgrade us.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Failed to open stream – wp-settings.php on line 118’ is closed to new replies.