Support » Plugin: Advanced Editor Tools (previously TinyMCE Advanced) » Failed to load plugin url: xxxx.com/wp-content/plugins/jetpack/

  • Resolved heykymmie

    (@heykymmie)


    Hello,

    My wordpress has been updated to 5.0 to which the editor has updated the UI.

    I go ahead and installed and activated the plugin, https://wordpress.org/plugins/classic-editor-addon/ to revert back to the classic editor

    However, going back to edit the post, I saw an error:

    “Failed to load plugin url: xxxx.com/wp-content/plugins/jetpack/_inc/build/contact-form/js/tinymce-plugin-form-button.min.js”

    *where xxxx.com is my website ur

    Is this an error in the jetpack or in tinymce? I can’t pinpoint.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Andrew Ozz

    (@azaozz)

    Sounds like an error on the server perhaps? Could be the file permissions are wrong, or something is blocking this file. Can also be some sort of caching thing. Try loading that file directly in the browser and see what happens. Ideally should see the actual file content (js code).

    Thread Starter heykymmie

    (@heykymmie)

    Hello @azaozz

    Thanks! I did try to load the URL directly on the browser,

    https://www.heykymmie.com/wp-content/plugins/jetpack/_inc/build/contact-form/js/tinymce-plugin-form-button.min.js

    And I got this:

    /* Do not modify this file directly. It is compiled from other files. */
    /* global grunionEditorView, tinymce */
    !function(){tinymce.create(“tinymce.plugins.grunion_form”,{init:function(n){n.addButton(“grunion”,{title:grunionEditorView.labels.tinymce_label,cmd:”grunion_add_form”,icon:”grunion”}),n.addCommand(“grunion_add_form”,function(){grunionEditorView.default_form?n.execCommand(“mceInsertContent”,0,”[contact-form]"+grunionEditorView.default_form+"[/contact-form]“):n.execCommand(“mceInsertContent”,0,”[contact-form /]")})},createControl:function(){return null},getInfo:function(){return{longname:"Grunion Contact Form",author:"Automattic",version:"1"}}}),tinymce.PluginManager.add("grunion_form",tinymce.plugins.grunion_form)}();

    Do you have any clue? Thank you!

    I just started getting this error: “Failed to load plugin url: xxx.com/wp-content/plugins/jetpack/_inc/build/contact-form/js/tinymce-plugin-form-button.min.js” as well. While I am still able to edit and modify my pages, the error loads on EVERY page and is getting annoying.

    Would love to see a solution too.

    I had the same problem and it looks like it is related to the classic-editor plugin vs. Jetpack.

    I uninstalled classic.
    Reloaded
    Reinstalled classic.

    It works.

    • This reply was modified 2 years, 3 months ago by cyrilmalka.

    Uninstalling classic would be acceptable if classic-editor were the problem; this is a Jetpack issue and, well, quite frankly, I much more prefer classic over gutenberg. Classic makes it so much easier to just code when you want to code instead of coding individual blocks at a time. Of course that’s just my opinion, but I’d even go as far to say I’d remove Jetpack before classic if this problem persists.

    I also tried: deactivated classic, reloaded, & reactivated again; then decided to deactivated, then uninstalled, reloaded, and re-installed & reactivated in that order, but both troubleshooting techniques failed after a day or so.

    Plugin Author Andrew Ozz

    (@azaozz)

    Most likely a problem on the server, either with permissions or some security setting. As @cyrilmalka points out, re-installing the plugin that has the failed file may help as it resets the file permissions.

    @heykymmie as you can see the file’s content in the browser (yeah, that looks like a minified JS, that’s the proper content), I’m assuming it is loading properly now. Could have been as simple as a cache issue that is now resolved 🙂

    • This reply was modified 2 years, 3 months ago by Andrew Ozz.
    Thread Starter heykymmie

    (@heykymmie)

    @lewissfowler

    NOTE: Only do the below steps if you are not using Jetpack’s Contact Form.

    if you are still having problems with the Edit mode because of the error, can you try to go to:

    xxxx.com/wp-admin/admin.php?page=jetpack_modules

    [where xxxx.com is your website’s domain]

    locate Contact Form from the list > Disable it,

    Then refresh the Edit form and the error shouldn’t pop up. It resolves the error xxxx.com/wp-content/plugins/jetpack/

    ashishrajsrivastava

    (@ashishrajsrivastava)

    @heykymmie that worked for me. Thanks for this tip.

    Thread Starter heykymmie

    (@heykymmie)

    @ashishrajsrivastava Happy to help! 🙂

    @heykymmie gracias… saludos desde Bolivia

    • This reply was modified 1 year, 9 months ago by Maik CPA.
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Failed to load plugin url: xxxx.com/wp-content/plugins/jetpack/’ is closed to new replies.