Support » Plugin: Autoptimize » Failed to load

  • Resolved Tony Zeoli

    (@tonyzeoli)


    Hey Frank,

    Can you take a look at the javascript errors for autoptimize on digitalstrategyworks.com. The site loads fine when I’m logged in to /wp-admin and I view the home page. When I’m not logged in, the site is broken. I tried turning on/off the autoptimize and async plugins and dumped the cache and everything. I just can’t seem to narrow down the issue.

    I’m not sure if it’s the plugin, the theme, or something else entirely, but seeing a lot of autoptimize failed to load errors in the jqvascript console.

    Thanks.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Can you try switching to static delivery of autoptimized files Tony?

    Tony Zeoli

    (@tonyzeoli)

    I will and will report back.

    Tony Zeoli

    (@tonyzeoli)

    Yep, that was it! Thanks, Frank!

    Tony Zeoli

    (@tonyzeoli)

    Whoops, one more question. That fixed the page from caching the old view to the new view, but now the drop downs for main menu don’t work.

    I have ASYNC enabled with Support for Autoptimize checked off. In the JavaScript option field, I’m also excluding the /theme/make/js.

    Also, Gravity Forms is not loading on this page: https://digitalstrategyworks.com/contact-us/payments/

    I have these scripts excluded: seal.js, js/jquery/jquery.js, /themes/make/js

    • This reply was modified 1 year ago by Tony Zeoli.
    • This reply was modified 1 year ago by Tony Zeoli. Reason: add excluded scripts
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    well, I see “jQuery is not defined” errors, so for starters exclude jQuery from being asynced (or disable asyncjs, get things working with just AO and then revisit asyncjs to see if/ how that can help you improve further)?

    frank

    Tony Zeoli

    (@tonyzeoli)

    Sorry, I’ve had some issues to address and haven’t been able to reply quickly. Thanks for staying with this.

    I tried every setting with asyncs and dumped the cache and still neither of the options worked. So, I’ve gone ahead and disabled ASYNC completely (across my multisite) because even if I just disabled the plugin from the admin and cleared the cache, I still had problems. It wasn’t until I deactivated both and cleared my cache that the site was not broken. Since then, I’ve disabled AO, cleared the cache, re-enabled AO and that’s where things lie at the moment. AO is enabled. I did not clear the cache after activating AO again. Let me know if from your POV everything looks like it’s operating correctly.

    Well, strike that. This page: https://digitalstrategyworks.com/contact-us/payments/ is not operating correctly, but the home page is. I see some errors, but I’m not qualified to understand what they are or why they are happening.

    Also, I did try cache wrapping and that affected the Gravity Form, so I disabled that now, as well.

    One more update – I turned off the inline CSS and that seems to have fixed it. Should I just run another above the fold CSS fetch and revise what’s in that field?

    • This reply was modified 1 year ago by Tony Zeoli. Reason: add additional information
    • This reply was modified 1 year ago by Tony Zeoli. Reason: disabled cache wrapping
    • This reply was modified 1 year ago by Tony Zeoli. Reason: Inline CSS disabled
    Tony Zeoli

    (@tonyzeoli)

    Let me start another post.

    So, I removed the CSS from inline CSS and disabled the feature and everything is now working.

    I guess I should just find the critical path CSS again and redo, is that correct?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    I guess I should just find the critical path CSS again and redo, is that correct?

    confirmed ๐Ÿ™‚

    Tony Zeoli

    (@tonyzeoli)

    For Critical CSS, I’m not sure which link in view source code to grab the CSS from. There are multiple CSS links – they are not being combined into one like I think had happened in the past. When you look at my source code, which CSS should I be copying and pasting into one of the Critical CSS sites?

    Also, I tried installing your Critical CSS add-on and it threw a 500 error in the admin, but not the front end, so I had to delete it.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    re. which CSS: the main one (the biggest in filesize for media=all).

    re. critical CSS add-on; that’s something I would like to fix, can you check the php-errorlog for relevant errors?

    Tony Zeoli

    (@tonyzeoli)

    Here’s a pastebin link of the error log from WP Engine: https://pastebin.com/FxqhtbZX

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    seems that the code to fetch custom templates (taken from https://codex.wordpress.org/Class_Reference/WP_Theme#Get_Custom_Page_Templates) is crashing … your theme’s gutenberg integration.

    [Mon Jan 07 03:21:31.244259 2019] [php7:error] [pid 12979] [client 97.82.233.223:20044] PHP Fatal error: Uncaught Error: Call to undefined function get_current_screen() in /nas/content/live/netmixcom/wp-content/themes/make/inc/gutenberg/manager.php:56
    Stack trace:
    #0 /nas/content/live/netmixcom/wp-content/themes/make/inc/gutenberg/manager.php(114): MAKE_Gutenberg_Manager->is_block_editor()
    #1 [internal function]: MAKE_Gutenberg_Manager->remove_page_template(Array)
    #2 /nas/content/live/netmixcom/wp-includes/class-wp-hook.php(288): call_user_func_array(Array, Array)
    #3 /nas/content/live/netmixcom/wp-includes/plugin.php(203): WP_Hook->apply_filters(Array, Array)
    #4 /nas/content/live/netmixcom/wp-includes/class-wp-theme.php(1099): apply_filters(‘theme_page_temp…’, Array, Object(WP_Theme), NULL, ‘page’)
    #5 /nas/content/live/netmixcom/wp-content/plugins/autoptimize-criticalcss/inc/core.php(175): WP_Theme->get_page_templates()
    #6 [internal function]: ao_ccss_extend_types(”)
    #7 /nas/content/live/netmixcom/wp-includes/class-wp-hook.php(286): call_user_func_array(‘ao_ccss_extend_…’, Array)
    #8 /nas/content/live/netmix in /nas/content/live/netmixcom/wp-content/themes/make/inc/gutenberg/manager.php on line 56, referer: https://netmix.co//

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    so

    Call to undefined function get_current_screen() in /nas/content/live/netmixcom/wp-content/themes/make/inc/gutenberg/manager.php:56

    is warned for in get_current_screen’s usage restrictions;

    This function is defined on most admin pages, but not all. Thus there are cases where is_admin() will return true, but attempting to call get_current_screen() will result in a fatal error because it is not defined.

    so guess the make devs will have to add some error handling to their code to prevent such ugly breakage?

    Tony Zeoli

    (@tonyzeoli)

    Okay, I’ll let them know. Thanks so much. So they’ll have to fix this in order for your plugin to not throw that 500 error.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    So theyโ€™ll have to fix this

    correct

    in order for your plugin to not throw that 500 error.

    well, technically it is the theme that is throwing the error, cfr. this entry in the stack trace;
    97.82.233.223:20044] PHP Fatal error: Uncaught Error: Call to undefined function get_current_screen() in /nas/content/live/netmixcom/wp-content/themes/make/inc/gutenberg/manager.php:56

    ๐Ÿ™‚

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Failed to load’ is closed to new replies.