Support » Fixing WordPress » Failed to import post tag

  • I have a live site on and am working to migrate it over to a self-hosted site on the .org platform. I got the WP platform installed fine on my own host and was able to successfully export an xml from the .com site and import it into the new site. That was a month ago.

    Since that time, I have been working on the new site by adding plugins, changing themes, etc. to get it working/looking the way I want before going live. I wanted to update the content on the new site by performing another export from the old site and importing into the new.

    However, this time I am getting the following error:

    Failed to import post tag
    ... [repeated multiple times]
    Failed to import post tag
    Failed to import
    Failed to import “cropped-20120423-155545.jpg”: Invalid post type
    ... [repeated multiple times with the different file names]
    Failed to import “Mango Caprese With Basil Pesto”: Invalid post type
    All done.  Have fun!

    I have searched high and low and it appears that others have had this issue but I haven’t seen a definitive fix. I’ve tried a couple of things including:

    – Creating new tables and pointing wp-config to these new tables.
    – Changing back to a default theme prior to import.
    – Unchecking the box for downloading attachments during the import process. I get the error regardless of whether the box is checked or not.

    The only difference on the platform between the original successful import and the subsequent failed import is the upgrade from WP 3.5 to 3.5.1 and the addition of new new themes and plugins.

    Any ideas? At this point I’m not even sure a completely fresh WP install will even work since the import still failed with new db tables.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator t-p


    -deactivating ALL plugins (yes, all) temporarily to narrow down the problem. If the problem goes away, re-activate them individually (one-by-one) to find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or phpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive). If applicible, also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old

    – To rule out any theme-specific issue, try switching to the unedited default twenty twelve theme for a moment using the WP dashboard. If you don’t have access to your admin area, you can switch to the default theme by renaming your current theme’s folder in wp-content/themes and adding “-old” to the end of the folder name using via FTP or SFTP or whatever file management application your host provides.

    Thanks for the suggestions, but all I’m getting is frustrated. I’ve tried:

    – Reverting back to the default Twenty Twelve theme.
    – Deactivating all plugins via the admin UI.
    – Deactivation all plugins by renaming the plugins folder in wp-content.

    Nothing worked…still same error.

    I didn’t try renaming the mu-plugins folder…where is that?

    I was browsing in the file manager and noticed that I have a public_html and a www directory, both containing the same files/folders.

    I changed the name of the plugin directory in the www directory and this seemed to work because the admin UI showed that I didn’t have any plugins.

    Was I also supposed to rename the plugins directory in the public_html directory also?

    I’m really baffled now. I created a new installation of WP in a /stage subfolder. After getting that up and running, I had a new fresh blog. I tried importing my export file and it still failed. I went to and created a new test blog with a single post and exported a backup file. I tried imported that little backup file into the new WP instance and it failed with the same errors.

    The only thing I can point my finger at is the 3.5.1 version. Surely the importer can’t be incompatible with this version or else someone else would’ve already caught it, right?

    Did you manage to resolve this? I am having the same problem – during the last month I have imported several WP installs to new sites, including from, and now all of a sudden I have the exact same problem you describe.

    I have tried different servers, new installs and so on, still doesn’t work.

    Moderator t-p


    Review these instructions and see if it helps:

    @microbe: Despite any similarity in symptoms, your issue is likely to be completely different because of possible differences in physical servers, hosts, plugins, theme, configurations, etc. Also, It’s easier for volunteers to help you if you have your own topic. Therefore, as per the Forum Welcome, please post your own topic. That way you might get more specific help. Also, posting in an existing topic prevents from being able to track issues by topic. 🙂

    It is not rational to blindly assume that that this is not the same issue or related. That is why I asked here.

    i bet it’s the 3.5.1 problem I have this too but never before 3.5.1. this is bad version.

    After days of searching, I finally found a work-around.

    I’m using a Mac with 10.7.5, not sure if this has anything to do with it, but figured it might help. I ended up downloading a program called “TarPit” which does gzip on a mac.

    The work around is here – … workaround

    *** from that article
    If your .xml data import is failing try the following
    (this method resolved this issue for me):

    1) Download and Install 7zip.
    2) Right click on your .XML file -> 7zip -> Add to Archive
    3) Change the “Archive format” to gzip and hit “OK”. You’ll now see your file with a .gz extension on it.
    4) Try to import/upload the file again (selecting the .gz you just created not the .xml file) and it should work.

    The first 2 times I tried this method I actually hit another error. Step 2 of the import ended up going to a “404 not found” page on the front end. To get around this I had to bump up the following settings in my php.ini:

    default_socket_timeout = 600
    pfpro.defaulttimeout = 600
    *** end **

    I tried using a gzip file (made under Mac Os) and still the same issue 🙁

    Got it work :
    1) Split the XML in two parts. In the first one put all tags and items other than posts. In the second file put all posts
    2) Use the following code for both files:

    <?xml version="1.0" encoding="UTF-8"?>
    <rss version="2.0" xmlns:excerpt="" xmlns:content="" xmlns:wfw="" xmlns:dc="" xmlns:wp="">
    *** Put here your data ***

    3) Load the first file
    4) Load the second file

    Images have not been loaded for all posts 🙁 But at least i have my posts !

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Failed to import post tag’ is closed to new replies.