WordPress Importer
"Failed To Import", "Invalid Post Type" Possible Workaround. (3 posts)

  1. Amber
    Posted 3 years ago #

    I have spent the past few days banging my head against a wall trying to figure out why the WordPress installations on some servers continually generate "Failed to import" and "Invalid post type" errors when trying to import a theme .xml file using this Importer plugin. In addition to the failures the .xml file was also not recognizing there were any authors in the file.

    Originally I had thought it might be an issue with a missing module/extension server side. I ended up testing this Importer in identical environments across different servers (shared, dedicated, vps, etc.) all with mixed results; sometimes it worked other times it didn't. I tried all manner of php.ini memory settings etc. with no luck. At this point I'm still not sure if it's server side or the plugin itself behaving badly.

    I FINALLY got the data to import and am posting my method for others to try to see if it helps them; not sure why it requires this process but importing the .xml would NOT work any way I tried on some servers until I used this method.

    If your .xml data import is failing try the following
    (this method resolved this issue for me):

    1) Download and Install 7zip.
    2) Right click on your .XML file -> 7zip -> Add to Archive
    3) Change the "Archive format" to gzip and hit "OK". You'll now see your file with a .gz extension on it.
    4) Try to import/upload the file again (selecting the .gz you just created not the .xml file) and it should work.

    The first 2 times I tried this method I actually hit another error. Step 2 of the import ended up going to a "404 not found" page on the front end. To get around this I had to bump up the following settings in my php.ini:

    default_socket_timeout = 600
    pfpro.defaulttimeout = 600


  2. ramzesimus
    Posted 3 years ago #

    Thank you very much. It works!

  3. Dr. Todd
    Posted 2 years ago #

    7zip doesn't work with IOS does it? I tried Keka.app.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress Importer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.