Support » Plugin: Google Analytics Dashboard Plugin for WordPress by MonsterInsights » Failed to fetch the new data from Google Analytics. Please reauthenticate on the

  • Resolved vahost

    (@vahost)


    I keep getting this alert message in my WordPress dashboard:

    “Failed to fetch the new data from Google Analytics. Please reauthenticate on the settings page!”

    I try to reauthenticate.
    1. I click “Re-authenticate with your Google account” on the General Settings tab.
    2. I click to Accept “View your Google Analytics data”
    3. I copy the “success code” from the page that follows.
    4. I paste in the General Settings tab in the “Paste your Google code here:” field.
    5. I click Save Changes.

    I get a successful save message, but a few clicks later, the error message reappears.

    Anyone know of a fix?

    https://wordpress.org/plugins/google-analytics-for-wordpress/

Viewing 15 replies - 151 through 165 (of 178 total)
  • Thank you, I’m using the manual way at the moment, and I have no dashboard.

    This annoying problem has happened to me too! I actually had to get my hosting company to deactivate all my plugins before I was able to login to my Dashboard. I found the manual way doesn’t work for me. I unchecked it, re-authenticated my Google Analytics, got the little code and pasted it in the box. Then chose my website user profile from the dropdown menu. Try this and see if it works for you!

    The weird thing is after every update from Yoast, I get the same error message again. But repeating the steps above fixes it for me. It’s just weird to have to keep doing it. Developers any clues to why this is happening?

    http://charmystique.com/

    I don’t get as far as this:

    @charmystique said: I unchecked it, re-authenticated my Google Analytics, got the little code and pasted it in the box. Then chose my website user profile from the dropdown menu. Try this and see if it works for you!

    There is no dropdown as I keep getting the message that there was nothing to save.

    @marky The dropdown menu is under General Settings > Analytics Account: All Website Data (it should show your UA code here).

    Did you uncheck the box (Manually enter your UA code)?

    My problem is fixed. If others are having problems, they should open a separate ticket.

    @charmystique, I’m in the same boat. The last few updates keep breaking it (maybe 2 weeks?). Fix it, it breaks. Fix it, it breaks. So not going to fix it again. Used to use manual settings, now I’m trying the automatic and no joy either way.

    Currently, I see the message, I go to the settings page and the code appears – it is there. Getting a bit tired of this.

    For anyone still having issues with this…

    I updated to 5.2.7 and still had the problem. I realised that my browser was not only copying the code but also the HTML formatting information. Once I removed the formatting info and submitted just the code it worked fine. (For the record I was using Google Chrome on an iPad)

    Yes I have done everything correctly and put in the correct code without any tags. And I still get the problem.

    “@marky The dropdown menu is under General Settings > Analytics Account: All Website Data (it should show your UA code here).

    Did you uncheck the box (Manually enter your UA code)?”

    Yes I did all of that, but still I am out in the cold.

    I just uninstalled it then re-installed it , re-authenticated, added the UA code but all I received for my troubles was:

    There were no changes to save, please try again. 🙁

    I have the same problem and it is not resolved. It keeps asking to re authenticate. I did it again just now.

    Got it — working now. It’s what @pillawake said in the comments on the page before. I wasn’t selecting my “profile” to prefill the box before re-authenticating. Duh! Thank you all.

    Like marky10000, I cannot authenticate with my Google account using the latest stable 5.2.7.
    After pasting in the code and pressing Enter, I get “There were no changes to save”

    I had the same issue. Turns out the plugin was stuck on ‘Settings’ in the left sidebar of the Admin panel. All I had to do was click on ‘Dashboard’, and everything came to life.

    Hope this helps.

    Anyone managed to get this resolved permanently without it prompting you to re-authenticate every now and then?

    I’ve updated to the latest version of this plugin, tried both methods – manually entering the UA code & tried selecting the correct “profile” I wanted to track. The settings was saved successfully but it comes back to haunt me at least once a day… help…!

    webingo I am in the same boat. No matter how many times I save it, the problem returns. Usually takes a few times…then it gives me the option to pick my user profile and says all is good, and then about a day or so later it’s back to square one. Was hoping the recent update would fix things, but hasn’t seemed too. Annoying bug.

Viewing 15 replies - 151 through 165 (of 178 total)
  • The topic ‘Failed to fetch the new data from Google Analytics. Please reauthenticate on the’ is closed to new replies.