Support » Plugin: Google Analytics Dashboard Plugin for WordPress by MonsterInsights » Failed to fetch the new data from Google Analytics. Please reauthenticate on the

  • Resolved vahost

    (@vahost)


    I keep getting this alert message in my WordPress dashboard:

    “Failed to fetch the new data from Google Analytics. Please reauthenticate on the settings page!”

    I try to reauthenticate.
    1. I click “Re-authenticate with your Google account” on the General Settings tab.
    2. I click to Accept “View your Google Analytics data”
    3. I copy the “success code” from the page that follows.
    4. I paste in the General Settings tab in the “Paste your Google code here:” field.
    5. I click Save Changes.

    I get a successful save message, but a few clicks later, the error message reappears.

    Anyone know of a fix?

    https://wordpress.org/plugins/google-analytics-for-wordpress/

Viewing 15 replies - 136 through 150 (of 178 total)
  • It looks great and all my sites is updated.

    @marky10000 Maybe you should try with the register code that provides you te button at the top of the square.

    The latest update worked like a charm. Thanks for your hard work on the fix @yoast team & @tacoverdo!

    I’m not sure what you mean pillawake

    @marky10000 Maybe you should try with the register code that provides you te button at the top of the square.

    Which button is that, the authentication button?

    I use the identification button and after the google analytics box comes up and I accept a little box comes up on yoast on my site and asks for the UA number which I enter and then it says there was nothing to save.

    Oops. Sorry. My english fails.

    General Settings.

    (try this)

    Analytics Profile => Select a profile

    Re-authenticate with your Google account|

    Paste your Google code and press return:

    (not this)

    Manually enter your UA code

    Hi pillawake, yes I have been doing that, pasting in my code.

    I’m not sure what you mean by this: Analytics Profile =========> |Select a profile v|

    My mistake. You must select your web profile in the fiel [Select a profile] I’ve seen that many people did’nt do it.

    I’ve added the code manually for the time being but I definitely cannot get it working so that I have a dashboard.

    @pillawake, I select my google profile.

    @marky10000
    Did you follow every step again?
    What i did was
    _Install again
    _Setttings again
    _Authenticate with the register Google account code provided, not with the UA
    _Enter UA code manually (to be sure)

    If its not, I’m really lost with your case…

    Please add me, too. I’m having the same problem. When it says to configure Google Analytics I’ve gone through the same process to re-authenticate several times adding the code and it’s still asking me to configure Google Analytics.

    I’ve even gone through the other tabs to be sure I’ve enabled Universal and Demographics. I’ve even tried troubleshooting in the debug mode tab and did notice some problems when I checked the console on my browser (Chrome).

    I have a screen shot I can provide if that would help. I also noticed after doing that when I go into my site it keeps blinking showing the URL of the page I’m on below.

    Hope this helps and gives you more information to go by. My site is “Plain Talk and Ordinary Wisdom“.

    Thank You

    Pat

    The latest update has fixed the problem for me. Thanks for the speedy fix!

    Same problem for my sites:
    Target Vision Media

    Thank you! “Failed to fetch the new data from Google Analytics” is fixed now. Thanks again for the latest updates.

    @marky1000, I’ll update the Installation Guide on kb.yoast.com today.

    @vahost, has your problem been resolved? If so, please mark this topic as resolved 🙂

Viewing 15 replies - 136 through 150 (of 178 total)
  • The topic ‘Failed to fetch the new data from Google Analytics. Please reauthenticate on the’ is closed to new replies.