Support » Plugin: Really Simple SSL » Failed to detect a valid SSL – but Qualys SSL Labs can

  • Resolved Musiphilos

    (@musiphilos)


    I have I new SSL certificate on my website, and Qualys SSL Labs test can find it, with an overall rating of B.

    For some reason outside of my understanding, Simple SSL states that

    Really Simple SSL failed to detect a valid SSL certificate

    On the other hand the https is working via browser. The browser is not loading all components because they still are coming from http, of course, but the browser does state a valid Certificate.

    Is there anything I can do to help Simple SSL find my Certificate?

    • This topic was modified 1 year, 5 months ago by Musiphilos.
    • This topic was modified 1 year, 5 months ago by Musiphilos.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    In the back-end, you can force Really Simple SSL to recognize the certificate by clicking the “reload over https” button, or by changing the URL to https in the browser, then hit enter.

    Then you can activate.

    Thread Starter Musiphilos

    (@musiphilos)

    Hi Rogier,

    Thank you so much for a quick reply.
    When I follow “reload over https”, it does visit the wp-admin page under https, but the layout is still broken as my browser console indicates that stylesheets and other “mixed content” are still being loaded via HTTP.

    Also, in that wp-admin page over https there is still the warning

    “Really Simple SSL failed to detect a valid SSL certificate… Reload over https”

    Maybe a printscreen might clarify my words better: https://www.dropbox.com/s/jm4kfs0om4rtkj7/2020-05-23%2021_19_15-SSL%20settings%20%E2%80%B9%20Institute%20For%20Systems%20and%20Robotics%20%E2%80%94%20WordPress.jpg?dl=0

    Cheers

    • This reply was modified 1 year, 5 months ago by Musiphilos.
    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    While on https, can you go to (your domain here)/wp-admin/options-general.php?page=rlrsssl_really_simple_ssl&tab=configuration

    Then check if there’s an “activate SSL” button there?

    If that doesn’t work, you can first try changing your home_url and site_url to https in settings/general.

    Thread Starter Musiphilos

    (@musiphilos)

    Thank you Rogier,

    I confirm that under that link there is no “activate SSL” element in the DOM.
    Also, after changing to https the home and site_url under “settings/general” my website is now showing a ERR_TOO_MANY_REDIRECTS (welcome.isr.tecnico.ulisboa.pt redirected you too many times.)

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    Can you try adding

    $_SERVER['https']='on';

    To your WP-config.php?

    Thread Starter Musiphilos

    (@musiphilos)

    Hi Rogier,

    Thank you for the tip. Unfortunately it hasn’t solved the problem(s) yet.
    I’ve added that code in wp-config.
    The option “activate plugin” in the &tab=configuration of Simple SSL is still not showing up because

    Really Simple SSL failed to detect a valid SSL certificate

    as seen on the PrintScreen bellow
    https://www.dropbox.com/s/e002oxfapldh5ea/2020-05-24%2009_50_04-Window.jpg?dl=0

    Also, I’ve activated debug mode and got this

    General
    Plugin version: 3.3.3
    Invalid SSL certificate
    SSL is not yet enabled

    Options
    * Mixed content fixer

    Server information
    Server: apache
    SSL Type: NA

    Detecting configuration
    Check SSL by retrieving SSL certificate info
    siteurl or home url defines found in wpconfig
    .htaccess does not contain default Really Simple SSL redirect

    Constants
    No constants defined

    I’ve tried to manually add the following code to .htaccess

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTPS} !=on [NC]
    RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
    </IfModule>

    which did exactly what I expected: forced 301 redirect (so no HTTP available via browsing) but certificate is still not found and mixed content problem persists.

    Anything I’m missing?

    Thank you for a great product and service

    • This reply was modified 1 year, 5 months ago by Musiphilos.
    Thread Starter Musiphilos

    (@musiphilos)

    Also, I followed some documentation recommendations and tried to force SSL with define('FORCE_SSL_ADMIN', true); and got

    ERR_TOO_MANY_REDIRECTS

    error on my website.

    Also visited https://staging-welcome.isr.tecnico.ulisboa.pt/wp-content/plugins/really-simple-ssl/ssl-test-page.php
    and got

    #SSL TEST PAGE#
    This page is used purely to test for SSL availability.
    #NO KNOWN SSL CONFIGURATION DETECTED#

    • This reply was modified 1 year, 5 months ago by Musiphilos.
    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    this domain:
    https://staging-welcome.isr.tecnico.ulisboa.pt/

    Does not have a valid SSL certificate, so won’t be able to load over https.

    To test it in staging, you’ll need a certificate there too.

    Thread Starter Musiphilos

    (@musiphilos)

    Dear Rogier,

    Thank you fo much fo your so Quik reply.
    Indeed there was a misconfiguration on the part of the certificate, that I was able to pinpoint as the culprit. That would be very likely because this is such a well-built plugin.

    Certainly considering the Pro now.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Failed to detect a valid SSL – but Qualys SSL Labs can’ is closed to new replies.