WordPress.org

Support

Support » Plugins and Hacks » Failed to create wp-content/aam folder

Failed to create wp-content/aam folder

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Vasyltech

    @vasyl_m

    Hi LordLiverpool,
    Do you have multisite network or single blog?

    Regards,
    Vasy

    Hi WP AAM

    Its a single blog.

    Cheers

    Plugin Author Vasyltech

    @vasyl_m

    HI LordLiverpool,
    It is hard to say what can be the cause. You can try to debug this issue. It might be the permissions issue or the path to wp-content folder is prepared incorrectly. Check the config.php file inside Advanced Access Manager plugin folder (lines 57-66).

    Regards,
    Vasyl

    Hi Vasyl

    Thanks for replying, I think its permissions.

    OK when I go Dashboard > AAM > Access Control

    I see “Failed to create wp-content/aam

    See Screen Shot Here

    So I connected to my server using Filezilla and manually created the folder aam

    Then I refreshed the page and I see “Folder wp-content/aam is not writable”

    See Screen Shot Here

    So I chmod the file permissions to 777 and after refeshing, everything seems fine

    See Screen Shot here

    So now I have a folder on my webserver that has file permissions of 777 which I know is not a good thing!!

    Months ago I installed AAM on another website and it worked fine on that website no problem.

    So I decided to compare file permissions of both websites.

    On the website thats OK, wp-content = 757
    On the website thats NOT OK, wp-content = 775

    1.) What file permissions should I set the wp-content folder too? (757?)

    2.) What file permission should I set the aam folder too? (757?)

    Both websites have the same path. I auto installed WordPress on both sites so I dont understand why they would have been created with different default files permission i.e. one with 757 and the other with 775.

    Can you please help, as I want to have secure websites.

    Thanks very much.

    Hi Vasyl.

    Do you have any idea what I should do?

    Cheers

    Plugin Author Vasyltech

    @vasyl_m

    Hi LordLiverpool,
    Linux permissions is more tricky than you can expect. I’m sure that your PHP is running on different user than your FTP user. That is why it might cause the issue.
    I would contact your server support team and ask them permissions for PHP to interact with file system. At least give PHP possibility to write inside wp-content and advanced-access-manager/extension folders.

    Keep me updated.
    Regards,
    Vasyl

    OK thanks I will let you know 🙂

    Hi,

    I’ve the same issue. Eveything is ok about rights but I still have “Failed to write file to wp-content/aam folder” when I try to register my license key ! And my ftp User is the same as the php user.

    Getting the same problem. Trying to solve it — I’ve made both directories completely open — and I still get

    Failed to write file to wp-content/aam folder

    Im running a standard word press install – hosted on my own EC2 instance from a bitnami image

    All I am trying to do is install my license — and I am 2 days into that step — Please advise.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Failed to create wp-content/aam folder’ is closed to new replies.