Support » Plugins and Hacks » [Resolved] Failed to create temp dir

[Resolved] Failed to create temp dir

Viewing 15 replies - 1 through 15 (of 20 total)
  • I’m having the same problem and found this post.


    I added the suggested code…

    * Constants

    define(‘SMUSHIT_REQ_URL’, ‘http://ws1.adq.ac4.yahoo.com/ysmush.it/ws.php?img=%s’);

    define(‘SMUSHIT_BASE_URL’, ”);

    and it solved the “temp dir” problem. But now I’m getting a 1 mb file limit error. I found another post that said Smush.it has a 1mb limit on the files it can work with. My files are larger than 1 mb, so I’ll have to look for another plugin to optimize images.


    Was having the same issue with the temp directory and your code fixed it steve. Thank you!

    Excellent, this is great. I added that extra code and it worked! Thanks steve. Before this plugin, I would already have saved for web from photoshop to reduce the MBs if that helps steve. Thanks again.

    Plugin Contributor Alex Dunae


    The ‘temp dir’ error is actually from Smush.it itself. I’m guessing that they fixed their servers while you were changing the SMUSHIT_REQ_URL code.

    Alex, I just upgraded all my websites this morning to 1.4.1, and I’m getting this message now for all of them. I can’t use your plugin right now. I went into wp-smushit.php inside your plugin folder, and changed the constants as per above, and still nothing is working.

    Will you have another update soon?


    I have this message for example :
    Smush.it error: Failed to create a temp dir while processing http://*****.com/blog/wp-content/uploads/2011/07/G5090711.gif (/homez.380/xxxxxx/www/blog/wp-content/uploads/2011/07/G5090711.gif).

    WordPress version : 3.2.1
    Smush.it : 1.4.1


    I have this message for example :
    Smush.it error: Failed to create a temp dir while processing http://*****.com/blog/wp-content/uploads/2011/07/G5090711.gif (/homez.380/xxxxxx/www/blog/wp-content/uploads/2011/07/G5090711.gif).

    WordPress version : 3.2.1
    Smush.it : 1.4.1

    Exact same issue as itoben.

    However in my case, i only get this message when trying to re-smush, or manually using the smush.it button in media library.

    Smushing works fine, when uploading the image manually, and the image uploads fine, and when i checked the media library, it also indicated i made some file size savings, hence why i know smush it works.

    Sadly i just wish clicking the smush it works as well, so i could smush my old uploaded images that haven’t been smushes just yet.


    Just 20 minutes ago i got this temp dir error, but now i try it again, and it works !!!

    Clicking smush.it in media library, and re-smushing also works. new and old image uploads.

    Now i am testing the mass smush.it to see if that works too.

    Anyway i think Alex is right, that this bug happens not because of his plugin, but probably because the yahoo smush.it service api is a bit wonky or something.

    Bulk smushing apparently works, but after 1 dozen images, it then gets the temp dir error again, and also this operation time out.

    Processing rafa-nadal-vs-novak-djokovic…
    – Reduced by 8.7% (870 B)
    – Reduced by 7.8% (1.6 KB)
    Processing wimbledon-2011…
    – Reduced by 5.4% (418 B)
    – Reduced by 4.9% (844 B)
    – Reduced by 4.9% (7.2 KB)
    – Reduced by 5.0% (1.7 KB)
    – Reduced by 4.5% (1.7 KB)
    Processing 403…
    – Reduced by 7.5% (690 B)
    – Reduced by 7.4% (1.5 KB)
    – Reduced by 6.5% (1.4 KB)
    – Reduced by 6.7% (1.3 KB)
    Processing sc2…
    – Reduced by 6.7% (637 B)
    – Reduced by 6.5% (1.3 KB)
    – Reduced by 5.0% (6.7 KB)
    – Reduced by 5.5% (1.9 KB)
    – Reduced by 4.6% (1.8 KB)
    Processing debug-bar-errors1…
    – Reduced by 13.1% (1.6 KB)
    – Reduced by 10.0% (1.2 KB)
    Processing debug-bar-sql1…
    – Reduced by 10.6% (1.4 KB)
    – Reduced by 9.0% (1.6 KB)
    Processing debug-bar-profiler1…
    – Reduced by 12.8% (1.1 KB)
    – Reduced by 10.2% (826 B)
    Processing debug-bar-globals1…
    – Reduced by 8.1% (573 B)
    – Reduced by 9.2% (1.6 KB)
    – Reduced by 11.0% (2.9 KB)
    – Reduced by 11.1% (2.9 KB)
    Processing debug-bar-black1…
    – Reduced by 14.7% (418 B)
    – Reduced by 11.2% (399 B)
    Processing hard-drive-labeled…
    – Reduced by 8.2% (826 B)
    – Reduced by 7.3% (1.4 KB)
    – Reduced by 7.6% (2.1 KB)
    – Reduced by 7.5% (1.9 KB)
    Processing header-zbench…
    Operation timed out after 25001 milliseconds with 0 bytes received

    From the log, apparently the bulk smushing is also smushing the different image sizes for the single image, which is nice.

    I just wish the yahoo smush service wasn’t so wonky.

    But i think individual image uploads/smushing shouldn’t be a problem.

    One image i got this error Smush.it error: Image size exceed 1MB limit while processing

    But at least it tells you it didn’t smush because of the limit.

    So that is good to know at least.

    Besides most of my images are usually below 1mb, so i don’t think this is too big a deal for me.

    Plugin Contributor Alex Dunae


    This seems to be an issue with Smush.it – see my comments in this thread.


    Now after a re-smush the status is : “no savings” even for the old files use before version of smush.it :s

    itoben, some of my images also have no savings. While some do.

    I’m not too surprised because some of these images i grabbed off google, so maybe someone else had already smushed it first.

    Take my word for it, the smushing works :}

    The only sad bit is, smushing doesn’t work for 1mb + file size :{ but at least it gives you a warning message if this is the case, so you know which images to single out.

    Plugin Contributor Alex Dunae


    The “no savings” message can occur when an image has already been smushed once – the plugin doesn’t currently save the original file size so it isn’t sure what the actual savings are.

    Plugin Contributor Alex Dunae


    I just got word from Yahoo! that Smush.it is being moved to new servers next week. Hopefully that will be the end of the errors.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] Failed to create temp dir’ is closed to new replies.