Support » Plugin: IBM Watson Assistant » Failed to create a table for task queue

Viewing 6 replies - 1 through 6 (of 6 total)
  • Anyone can help? Is this forum active?
    However, I use Ubuntu 16 xenial, PHP 7.0.33-0ubuntu0.16.04.5, 5.7.26-0ubuntu0.16.04.1 and tested with WordPress 5.2.1 and 5.1. Always the same issue.

    Plugin Support intelahelp

    (@intelahelp)

    Hello @sasadangelo1974!

    We are looking into it.

    • This reply was modified 2 months, 1 week ago by  intelahelp.

    Thank you

    Plugin Support intelahelp

    (@intelahelp)

    Hello @sasadangelo1974!

    We have completed all the tasks on your list (from your email) to reproduce the problem. All tables were created, including a table for the task queue.
    But we found another error – “500 Internal Server Error” when communicating with chatbot. This error occurs due to the lack of a “curl” extension for php. You need to follow these steps to fix the error:

    1. cd <work_dir>
    2. git clone https://github.com/ibm-sanpa/SanPatrignanoWebsiteChatbot
    3. cd SanPatrignanoWebsiteChatbot
    4. vagrant up
    5. Open Ubuntu where your site is running in Virtual Box and enter “webuser”/”webpwd”
    6. Update the system packages with the command: sudo apt-get update
    7. Set php-curl: sudo apt-get install php7.0-curl
    Next steps on your Mac:
    8. sudo vi /etc/hosts
    9. Add this line to /etc/hosts on your Mac:
    192.168.100.2 http://www.sanpa.org
    10. Open the browser and go to http://www.sanpa.org
    11. Open http://www.sanpa.org/admin insert user/password and configure the plugin with API credentials.
    12.Go to http://www.sanpa.org/ and make sure the chat is working

    If you have any questions, feel free to ask them.

    • This reply was modified 2 months ago by  intelahelp.
    • This reply was modified 2 months ago by  intelahelp.
    sasadangelo1974

    (@sasadangelo1974)

    Hi,

    Just realized that in my code I imported an sql containing old tables of the plugin. When the plugin was installed they prevented the creation of the new one. Fixed this issue error messages disappeared but the welcome message didn’t appear on the chatbot.

    Your suggestion:
    apt-get install php7.0-curl

    fixed the issue.
    Thank you.

    Plugin Support intelahelp

    (@intelahelp)

    You are welcome!

    If you have any questions, feel free to ask them.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.