• Hello,
    I’ve recently installed this plugin and I am having an issue with connecting to my SSRS. I believe the Report Server URL is correct (I am using the one found in the Report Server Configuration Manager) and the user details I am using has the Content Manager role.

    Any tips or tricks that I might be overlooking?

    Thank you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Module Masters

    (@modulemasters)

    Can you provide some more information, what is the error message you are seeing? What version of SSRS reporting services are you using?

    Thread Starter curiousadmin

    (@curiousadmin)

    Hello,
    Thanks for the quick reply!

    The error message I am getting whenever I attempt to access the page where I have posted the shortcode is as follows:
    “SSRS SHORT CODE ERROR
    Failed to connect to Reporting Service
    Make sure that the url (http://genericservername/ReportServer/) and credentials are correct!”

    We are utilizing SSRS 2017 version 14.0.600.906.
    Thank you.

    Plugin Author Module Masters

    (@modulemasters)

    Did you modify the report server configuration to allow “Basic” authentication?

    Thread Starter curiousadmin

    (@curiousadmin)

    Hello,
    I did set up basic authentication, but it was my first time doing so. Would you have a video tutorial you would recommend that walks you through that?

    Thank you.

    Plugin Author Module Masters

    (@modulemasters)

    We don’t have any video other than the documentation we reference on the Microsoft site. What are you using for the report server URL? Did you try accessing it from the web server that is hosting the wordpress site to verify that it is accessible? It must be accessible from the web server that is running the wordpress site (e.g. there can be no firewall or network issues).

    nellisw

    (@nellisw)

    I am having a very similar issue. I’ve edited the RSReportServer.config file to this:
    <AuthenticationTypes>
    <RSWindowsNTLM/>
    <RSWindowsBasic/>
    </AuthenticationTypes>

    The User for the reports has access in SSRS and SQL Server and can access all the reports by directly logging in at the SSRS Website.

    However, the plugin is returning the error:
    SSRS Short Code Error
    Failed to connect to Reporting Service
    Make sure that the url (http://MySSRSURL/ReportServer/) and credentials are correct!

    What else can I try to resolve this error?
    Thanks!

    Plugin Author Module Masters

    (@modulemasters)

    Is the web server hosting the WP site on the same local network as the SSRS server? Can you confirm connectivity from the actual web server to the SSRS server and make sure there is not a firewall issue? Are you sure you are using the correct URL to the report server? Can you post a screenshot of your settings or email it to service@modulemasters.com

    nellisw

    (@nellisw)

    Hi,

    Thank you for your quick response! I started writing an email with screenshots of everything I tried and realized there was one pattern I had not tried yet. I changed the Report Server URL in your settings screen from http://MyDomainName/ReportServer to http://MyServerIP/ReportServer and everything started working.

    I wanted to post the answer here so it could possibly help others. I don’t really understand why the IP change makes such a difference; using a browser to get to reports works fine with either the domain or the IP.

    Just for reference, my WordPress site is hosted at SiteGround, while my SQL/SSRS Server is on a Hostwinds VPS.

    Thanks again and I will be looking forward to using your great plugin!!!

    Plugin Author Module Masters

    (@modulemasters)

    Excellent! Could be some DNS issue or something that was happening, good idea trying by IP.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Failed to connect to Reporting Service’ is closed to new replies.