WordPress.org

Forums

[resolved] Failed to connect to FTP Server lawrencesql.db:21 (3 posts)

  1. emlawrence
    Member
    Posted 2 years ago #

    I got my domain from nearlyfreespeech and they say I have to enable file uploading by navigating to the wordpress folder and entering this in terminal:

    cd wp-content
    mkdir uploads
    chgrp web uploads/
    chmod 775 uploads/

    I also found this page:
    http://diegobenna.blogspot.com/2013/07/wordpress-solution-failed-to-connect-to.html
    which says to navigate to wordpress on your localhost and put in:
    sudo chown -R www-data:www-data *

    Here's the problem:
    I can't navigate to my wordpress. I realize this is a simple problem, but I have no idea how to navigate. It is in /home/public/ (where nearly free speech recommended I post it). So i tried
    cd /home/public/
    and get terminal telling me there is no such file or directory. I tried ls -la to view all the folders in /home/ and got a root and an admin option, which means I'm probably looking at my /home/ directory LOCALLY and not on my SERVER. So how do i get to /home/ on my localhost?

    Thanks!

  2. emlawrence
    Member
    Posted 2 years ago #

    Clarification:
    I'm trying to get WordPress to upload media/themes/plugins and it won't. I get the error 'Failed to connect to FTP Server lawrencesql.db:21' every time I enter my hostname, username and password. They are all definitely correct.
    So I did a search and found the above solutions, but I need to navigate to wordpress on my server in order to get them to work. I don't know how to do that.

  3. emlawrence
    Member
    Posted 2 years ago #

    I tried typing in my shell to find my home path to wordpress:
    <?php $path = get_home_path() ?>
    and I got a syntax error. I just need to find my home path and I can't seem to get it to work. Can anybody help?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.