Support » Fixing WordPress » Failed to connect to FTP Server

  • Can anyone help please- i’ve been stuck with this for a while…

    Whenever i try and add a new theme or plug-in i get a window prompting for Hostname / Username / Password / Connection Type . The correct details (I have double checked all these from GoDaddy for the ftp connection details) do not work. I get the message: “Failed to connect to FTP server”

    I have read many threads on this and tried using “localhost” or “localhost:21” instead of real ftp name which i understand sometimes works but doesn’t work in this case.

    Some info: WordPress 2.9.2. Hosted on GoDaddy, and WordPress intalled by GoDaddy by their “Auto Install”. Host server is Linux. I’m using a Mac with OS X 10.5.8. I am able to go on ftp with CyberDuck ftp server and also through GoDaddy’s online ftp server.

    Would really appreciate any help- i’m so stuck :-[

Viewing 7 replies - 1 through 7 (of 7 total)
  • I am also getting this error message even though I can upload to the site through FileZilla just fine. It is maddening!!! I am trying to set up a WP site for a client and can’t get any plugins functioning. Does anyone know the answer to this?

    I have this problem with GoDaddy as well … it would be nice if someone could shed some light on this. I manually installed WordPress on GoDaddy’s Windows (IIS 7) shared hosting service. I am able to use FileZilla to manually upload plug-ins, themes, and so on, but the automatic install / upgrade doesn’t work.

    What gives?

    Trevor Sullivan

    ditto. Is it godaddy?
    I need this fixed asap. Any suggestions?

    I’m having the same problem as well, on the server which hosts my sites. It’s a local provider, and not GoDaddy or any other big ones. I suspect it has something to do with the ftp authentication, since when I normally login to sftp with Filezilla it logins into the following address:


    Now when the auto install runs for a theme and it asks for ftp or sftp, it seems to default to port 21, but in my case, our server runs their sftp on port 22, not 21. I’ve tried every permutation I can think of for host names, with and without ports, with no success. When I do a manual login test without the port number in Filezilla it says my host is running SSH-1.99-OpenSSH_4.6-sshjail.

    Not sure if this helps at all, or what port others may need to login to. It’s really a shame that this auto install isn’t working, and have to go back to the old ftp work around… 🙁

    I am having these exactly same issues. I have wordpress installed on my own server, but can’t update or install through the wordpress dashboard. Frustrating!!

    use LOCALHOST at hostname fileld, but not your actual address

    @karamba – no luck, already tried that too and the server still refuses the connection. I also tried localhost:21 and localhost:22 with similar results.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Failed to connect to FTP Server’ is closed to new replies.