"Failed to connect to FTP" error when upgrading plugins (4 posts)

  1. mockngbrd432
    Posted 3 years ago #

    We have 2 WP (version 3.0.3) websites running on the same server (GoDaddy: Shared server) for more than a year. Im trying to update the plugins used in the websites to the latest versions. The plugins updated properly in one website but in the other I'm asked for FTP credentials and getting the following error "Failed to connect to FTP" and unable to update the plugins.

    I have checked the forums and tried the following.
    1. Added 21 at the end of hostname.
    2. Tried http://ftp.hostname.com, hostname.com and localhost with and without 21 at the end.
    3. Given 777 permissions for entire wp-content folder.

    The same FTP credential works with FileZilla/FireFTP and I'm able to add/update files.

    The website is hosted on a shared server, so probably I cannot SSH into server like the following link says..

    Is there any way to solve this problem?
    I'm stumped why one website worked good and the other has problems even though they are running on the same server..

    Someone please help me get this resolved..


  2. davidshq
    Posted 2 years ago #

    Have you figured out a resolution to this issue? I'm seeing it as well.

  3. mockngbrd432
    Posted 2 years ago #


    In that particular case, we manually uploaded the plugins and then activated them.

    We had this same problem in a different website running WordPress 3.5. Here we added FTP information in wp-config.php like the following to solve...

    define('FS_METHOD', 'ftpext');
    define('FTP_USER', 'USERNAME');
    define('FTP_PASS', 'PASSWORD');
    define('FTP_HOST', 'HOST NAME');
    define('FTP_SSL', false);

    Hope this helps.

  4. davidshq
    Posted 2 years ago #

    Thanks, in my case it ended up being a file permissions issue.

Topic Closed

This topic has been closed to new replies.

About this Topic