Support » Plugin: NS Cloner - Site Copier » Failed to Clone the main site #1

  • Resolved rcomienda



    I want to clone my main site First I have tested the plugin with others sites (subdomains), and it worked great, but when I tried to clone the main site ID=1, failed for the following error, and has not cloned me anything:

    “The Source Site Name (rComienda) may not appear in the Target Site Domain ( or data corruption will occur. You might need to edit the Source Site’s Name in Settings > General, or double-check / change your field input values.”

    Do you have any idea?


Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Never Settle


    Hello! The scenario is a little tricky to describe in words, but if you follow the error warning extremely literally it should point you in the right direction. It describes exactly what is going on and how to fix it.

    You need to go to the Settings > General page for the main site you are trying to clone – in this case Then, in the Site Name field you need to change that to something else. It cannot be just “rComienda” by itself because that word is also in the domain name and it will corrupt the new clone because of the automatic replacements that have to happen for the clone site to work properly. Every clone starts out as an exact copy, but you can’t have two of the exact same sites (same domains, same folders, etc.). So the Cloner makes intelligent replacements to make the clone’s naming unique based on what you put into the settings.

    However, it will detect situations like this where corruption will occur.

    Just go into Settings > General for and change the Site Name to something other than “rComienda” – it can be something like “rComienda Main Site” or anything – it just can’t only be identical to any part of the domain name by itself. After you make that update it should work just fine.

    Hopefully that is more clear now. Regards!


    It ran fine now 🙂


    Plugin Author Never Settle


    Right on! Glad it worked or you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Failed to Clone the main site #1’ is closed to new replies.