Support » Plugin: MailChimp Forms by Optin Cat - Grow Your MailChimp List » Failed to add user – 400

  • hi
    our opt-in for has stopped working its Version 2.4.1 on WordPress version 5.2.3,

    from the back end, the API key is good and our correct MailChimp lists are displayed in MailChimp I can see that GET’s for the list name is working

    but when a user fills In the form they get a Failed to add user – 400 error

    and I can see in MailChimp a failed GET

    2019-10-04 11:58:59 GMT nope 185.80.133.137 GET /lists/…/members/…/ php 0.014s WordPress/5.2.3; http://greaterbrislington.org 3.0 The requested resource could not be found.

    and a Failed PUT

    2019-10-04 11:59:00 GMT nope 185.80.133.137 PUT /lists/…/members/…/ php 0.042s WordPress/5.2.3; http://greaterbrislington.org 3.0 Your merge fields were invalid.

    so far as I’m aware we’ve not changed anything in the MailChimp list / subscribe since this was first set up and it did work originally its been broke ni think for maybe a month or so

    if you can give any help or advice that can get us back up and runnning that would be awesome

    thank you Dougal

Viewing 4 replies - 1 through 4 (of 4 total)
  • hi @fatcatapps please can you respond to this request for help with your plugin

    hi
    our opt-in for has stopped working its Version 2.4.1 on WordPress version 5.2.3,

    from the back end, the API key is good and our correct MailChimp lists are displayed in MailChimp I can see that GET’s for the list name is working

    but when a user fills In the form they get a Failed to add user – 400 error

    and I can see in MailChimp a failed GET

    2019-10-04 11:58:59 GMT nope 185.80.133.137 GET /lists/…/members/…/ php 0.014s WordPress/5.2.3; http://greaterbrislington.org 3.0 The requested resource could not be found.

    and a Failed PUT

    2019-10-04 11:59:00 GMT nope 185.80.133.137 PUT /lists/…/members/…/ php 0.042s WordPress/5.2.3; http://greaterbrislington.org 3.0 Your merge fields were invalid.

    so far as I’m aware we’ve not changed anything in the MailChimp list / subscribe since this was first set up and it did work originally its been broke ni think for maybe a month or so

    if you can give any help or advice that can get us back up and runnning that would be awesome

    thank you Dougal

    Plugin Author fatcatapps

    (@fatcatapps)

    Hello Dougal,

    Thanks for the details. We will see how we can help.

    We don’t have any other users experiencing similar problems that I’m aware of right now. So the first place to start is to make sure the other softwware on your site is not somehow causing interference. A new plugin, or an update, could be causing a conflict.

    To search for conflicts, please follow these steps.

    1. First please deactivate all plugins except Optin Cat and see if the issue persists.
    2. If the issue is resolved, reactivate your plugins one by one, testing after each to see if the issue returns.
    3. If no conflict is found among your plugins, try reverting to a default WP theme like ‘Twenty Sixteen’, or ‘Twenty Seventeen’, and see if the issue is resolved.

    Head here for detailed instructions:
    https://fatcatapps.com/knowledge-base/search-for-conflicts/

    Let us know your results, and we will go from there.

    Regards,

    hi

    we’ve tried selectively disabling plugins – we only have a couple of others but this hasn’t made a difference we’re running the latest version of your plugin and the latest WordPress there’s at least one other user who’s posted on this thread experiencing the same issue the plugin seems t ofunction but is failing in its dialog with mailchimp as per

    from the back end, the API key is good and our correct MailChimp lists are displayed in MailChimp I can see that GET’s for the list name is working

    but when a user fills In the form they get a Failed to add user – 400 error

    and I can see in MailChimp a failed GET

    2019-10-04 11:58:59 GMT nope 185.80.133.137 GET /lists/…/members/…/ php 0.014s WordPress/5.2.3; http://greaterbrislington.org 3.0 The requested resource could not be found.

    and a Failed PUT

    2019-10-04 11:59:00 GMT nope 185.80.133.137 PUT /lists/…/members/…/ php 0.042s WordPress/5.2.3; http://greaterbrislington.org 3.0 Your merge fields were invalid.

    Hi,

    I am getting the same issue here.

    I have tried to create a new pop up form and I get the same problem.
    In MailChimp I had some fields which were mandatory and I removed those and I still get the error.
    In WordPress OptinCat, within the subscribers menu I get the following:
    failed to add to mailchimp [400]

    Thanks,
    Jay

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.