Support » Plugin: Daily logo » Failed to activate

  • Resolved mhesk

    (@mhesk)


    Plugin couldn’t be activated. The error is as follows:
    Warning: require_once(__DIR__/daily-logo-constants.php) [function.require-once]: failed to open stream: No such file or directory in *site*/wp-content/plugins/daily-logo/daily-logo.php on line 33
    Any ideas?

    https://wordpress.org/plugins/daily-logo/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Andrea Landonio

    (@lando1982)

    Hello, can you give me more informations about your WP version and your stack? eg: windows, apache, mysql.. every information could be useful..

    Thanks,
    Bye

    Hello,

    WP 4.4
    MariaDB PHP 5.5

    That’s all the information I have readily from my provider.

    Thank you.

    Plugin Author Andrea Landonio

    (@lando1982)

    Hello,

    I’m trying on my PC.. Is it possible for you to ask some logs to your provider?

    I only got to the error log, which is just a collection of error messages – the same as I have already posted.

    Plugin Author Andrea Landonio

    (@lando1982)

    Hello,

    I have done a test with WP4.4 and MariaDB and it’s work for me.. probably the error should concern the provider application server. Can you read in the provider docs if the server is Apache, nginx, etc? And, can you search if the provider uses linux or windows?

    Please give me this info.. 😉
    If you’re agree give me the provider name.. I can search for you..

    Plugin Author Andrea Landonio

    (@lando1982)

    Closed for no response

    Hi.

    I had the same problem. It occured __DIR__ constant was not defined on my provider’s environment. Workaround was described here. I inserted following code at the begining of daily-logo.php file:

    if(!defined('__DIR__')) {
        define('__DIR__', dirname(__FILE__));
    }

    Works like a charm.

    Best regards.

    Plugin Author Andrea Landonio

    (@lando1982)

    Thanks mkupis,
    I’ve updated the plugin code!
    😉

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Failed to activate’ is closed to new replies.