Support » Fixing WordPress » Failed Theme Launch. failed to open stream…

  • I have posted this question to the author of the theme, but am looking to get the my site back up and operational as soon as possible.
    I installed the theme using the wp uploader and i have a line on the installation that the “Theme installed successfully”

    Then I receive the following 3 warnings:
    Warning: fopen(/home/nextstep/public_html/wp-content/themes/U-Design-WP-Theme/style.css) [function.fopen]: failed to open stream: No such file or directory in /home/nextstep/public_html/wp-includes/functions.php on line 4339

    Warning: fread(): supplied argument is not a valid stream resource in /home/nextstep/public_html/wp-includes/functions.php on line 4342

    Warning: fclose(): supplied argument is not a valid stream resource in /home/nextstep/public_html/wp-includes/functions.php on line 4345

    If I activiate, I receive the message that the theme is broken. Reverting to the default theme.

    I loaded a few different themes to test and I also reinstalled WP 3.2.1 and the default theme loads fine.

    Two questions:
    #1 what tool is available to identify line numbers to locate the lines, 4339, 4342, & 4345?
    #2 I suspect the function is looking for a function or a directory? Can I just enter the information if I can find the right location?

    I’m fairly new and have been reading the documentation and have not found anything that can answer my question. I’m sure it is not a rare problem and I hope someone can help provide a few directions I can try.

    Thank you everyone!,
    Russ

  • The topic ‘Failed Theme Launch. failed to open stream…’ is closed to new replies.