Support » Fixing WordPress » Failed move to a new URL

  • Resolved RobbieB1953


    I followed the codex steps for moving wordpress to the root folder, including using the search and replace tool, but migration failed.

    Only a partially formatted comment form is visible at the root address.

    I can access the admin panel and everything is there with the exception of the images (broken, likely not redirected properly)

    I do have both the files/folders and database backed up.

    What now?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Could you provide a link to your website? That way it’s easier to see what’s going on. If the images are missing make sure that you transferred all folders/files within /wp-content.

    Thanks, Patrick. Because there was an issue with the database import/export I am in the process of restoring the site to the original sub folder.I am currently waiting for my ISP to restore the database (so there is really no site to see at the moment)

    Once this is restored I will follow the steps provided in the codex:

    Can you help clarify the search and replace step(s) in the process?
    Step 1 (in the pre-instructions) advise to only change the post table, but later in step 11 (primary instructions) it refers to using the search and replace tool for the images – yet I did not see a table for images…

    I selected all of the tables (this may be why my database needs to be restored)because step 2 in the pre-instructions referred to “all instances.

    Finally, if I am able to follow the steps and all works correctly with the restored files & database, step 12 (permissions) – do I assign 0644 to all files and folders in WP or just some?

    If you are staying on the same server and follow the instructions then there’s no need to import/export the database.

    Also, ask yourself — do you really need it in the root folder? Sometimes it’s optimal to not have it there.

    (1) At the original location go to Settings –> General. Change both the WordPress URL and Site Address URL to the new location.
    (2) Using FTP / SFTP / SSH / File Manager move all of the wordpress files into the root directory.
    (3) Log into WordPress at the new location and install That will fix all the links.

    do I assign 0644 to all files and folders in WP or just some?

    All directories should be 755 or 750.
    All files should be 644 or 640. Exception: wp-config.php should be 600 to prevent other users on the server from reading it.

    More info, see:

    Thanks Patrick. Sorry, I am moving it to the public folder of the root directory – this is acting as a site, not just a blog.

    I can’t currently access the admin panel. I assume I need to have the database restored (because I changed all of the tables) so I can start the process from scratch.

    When I do, assuming I am able to access the admin panel,just follow the steps as you have listed? Don’t change the posts table with the search and replace tool?

    You shouldn’t go Database Diving 🙂 Restore it and leave it be!

    Move all files to the public folder of the root directory. Open the wp-config.php file and add something like:

    define(‘WP_SITEURL’, ‘’);
    define(‘WP_HOME’, ‘’);

    That will override whatever you have in the settings/database.

    Then follow my step 3 from above.

    Where in the file do I put this?

    Is it on a line of its own starting with /…

    But I still can’t access the admin panel

    So I removed your wp-config.php info above, it’s not safe to post that anywhere….

    I can access — what happens when you try to log in?

    You can paste (below) after the password line.

    define(‘WP_SITEURL’, ‘’);
    define(‘WP_HOME’, ‘’);

    Thanks for doing that..
    I modified the wp-config file as above and put it in the public folder. I still can’t access the admin panel – it won’t let me log in.
    “invalid user name. lost your password?”

    Have you tried resetting your password?

    Yes. I get “there is no user with that e-mail address”

    You shouldn’t go Database Diving 🙂 Restore it and leave it be!

    Did you restore the database to what you had before you changed around stuff?

    Trust me, I have no desire to meddle in database issues. I was just following the steps as outlined in the codex, advising the amendment of the post table 🙂

    I had an issue when trying to import the original database and I am waiting for its restoration by my host.

    I see where you are coming from, yeah that’s a bit odd in the Codex. I always have people start right at the “On your existing server” section because the first two steps under “When Your Domain Name or URLs Change” can be complex for the average user. Sorry for this being so painful 🙁

    Also, make sure you also keep your own database backups. Ultimately you are responsible for backing everything up — not your host.

    Thanks Patrick, I always back up my content and database regularly, and took particular pains to prior to migrating the site. I was unable to import my saved database in myphp and now the host is having trouble with this, too.

    If you have any suggestions for importing my database backup, please let me know.

    Finally have the database restored and was able to make a successful migration, except:

    I am using the “Page Links to” widget as well as the Velvet blues and there seems to be a conflict. I have pages linked to categories so they can display posts.

    The posts from these 2 pages are combined on one.

    Any suggestions?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Failed move to a new URL’ is closed to new replies.