Support » Plugin: WP-Members Membership Plugin » Failed Login leads to wrong page contents

Viewing 8 replies - 1 through 8 (of 8 total)
  • MrFerriero

    (@mrferriero)

    Having the same issue at http://authors.twistedplays.com/

    vikas.nagpal

    (@vikasnagpal)

    We found that it works fine in plugin version 3.1.9, and does not work in version 3.2.0.

    Regards
    Vikas

    airdrummer

    (@airdrummer)

    works 4 me @ cardinalglen.org/login

    avp7

    (@avp7)

    Same issue – user types in wrong password, and is taken to a home page that shows blog posts (not our proper home page). I’m working on a local site, so I can’t share a link, but WP version 4.9.8, WP-Members version 3.2.3.1 (just updated it today, which did not resolve the issue).

    Thanks!

    Plugin Author Chad Butler

    (@cbutlerjr)

    I was finally able to reproduce this and track the issue. When WP is set to use a static front page and login is done on the front page, the inclusion of the WP-Members action variable in the WP query_vars array causes this behavior.

    I am evaluating options regarding this particular issue. The “quick fix” is to remove the filter. This filter was added in 3.2 (which is why everyone has mentioned that there is no issue in earlier versions). I know that it was added for a specific reason but I cannot currently find development notes on why that was, so I am hesitant to simply remove it at this time. I will try to find a workaround and then if that fails, it will have to be removed regardless.

    This is probably going to take awhile so in the meantime the solution is to simply remove the filter. In the current version (3.2.3.1), it is at line 340 of /inc/class-wp-members.php.

    add_filter( 'query_vars', array( $this, 'add_query_vars' ) );

    Either comment out the line or remove it altogether until I have found a more permanent solution.

    MrFerriero

    (@mrferriero)

    That worked for me – thanks!

    avp7

    (@avp7)

    Also worked for me, and not seeing any issues arising from commenting out that filter. Thank you!

    Plugin Author Chad Butler

    (@cbutlerjr)

    Thanks for the info – I’m pretty sure the change in 3.2.4 is going to be to remove that line for now.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Failed Login leads to wrong page contents’ is closed to new replies.