Support » Plugin: Print-O-Matic » Failed in Mozilla Firefox

  • Resolved dawink

    (@dawink)


    Hello,
    I have a problem with Mozilla Firefox.

    When I print my coupon with Google Chrome, no problem.

    On the other hand, when I print with Firefox, I do not have the image of my coupon in print. It prints a frame with a missing image icon.

    For info, with firefox, after a few seconds, I am redirected to an error page of my site whereas with Chrome, I stay on the page of my coupon …

    Thank you for your help !

    With Chrome
    > Page website
    site with chrome

    > Coupon print
    coupon with chrome

    With Firefox
    > Page website
    site with ff

    > Coupon print
    coupon with firefox

    THX

Viewing 6 replies - 1 through 6 (of 6 total)
  • dawink

    (@dawink)

    I share my code

    [vc_row]
    [vc_column width="1/2"]
    [vc_single_image image="1782" img_size="full" alignment="center" onclick="link_image" css_animation="appear" el_class=""]
    [vc_column_text]
    <p style="text-align: center;"><button id="myButton" class="printomatic" data-print_target=".bon_de_reduction_kb-isma_wraper">Imprimer ce coupon</button></p>
    [/vc_column_text]
    [/vc_column]
    
    [vc_column width="1/2"]
    [vc_single_image image="1712" img_size="" alignment="center" css_animation="appear" el_class="image2_wraper"]
    [vc_column_text]
    <p style="text-align: center;"><button id="myButton" class="printomatic" data-print_target=".image2_wraper">Imprimer ce coupon</button></p>
    [/vc_column_text]
    [/vc_column]
    [/vc_row]
    
    [vc_row]
    [vc_column width="1/2"]
    [vc_single_image image="1743" img_size="" alignment="center" onclick="link_image" css_animation="appear" el_class="image3_wraper"]
    [vc_column_text]
    <p style="text-align: center;"><button id="myButton" class="printomatic" data-print_target=".image3_wraper">Imprimer ce coupon</button></p>
    [/vc_column_text]
    [/vc_column]
    
    [vc_column width="1/2"]
    [vc_single_image image="1744" img_size="" alignment="center" css_animation="appear" el_class="image4_wraper"]
    [vc_column_text]
    <p style="text-align: center;"><button id="myButton" class="printomatic" data-print_target=".image4_wraper">Imprimer ce coupon</button></p>
    [/vc_column_text]
    [/vc_column]
    [/vc_row]
    Plugin Author Baden

    (@baden03)

    Wow, you provided quite a bit of info! The most useful bit would be a link to your page.
    is the url to the image a full url or relative?
    are you providing enough time using the pause_before_print option for the images to load?
    do you have any js errors on the display page, before you try to print?
    You seem to be using the roll-your-own method for inserting the print trigger…
    Where did you learn how to do this? Are you also including the matching hidden print-me shortcode so that the correct js is placed on the page?

    Hello
    I am the person who harassed you by mail … ^^;)

    The site is in maintenance mode. I send you the identifiers on your email?

    It suits you ?

    Plugin Author Baden

    (@baden03)

    Hello. We took a look at your site, and here are the following issues.

    First of all, you can not use the same ID on multiple elements. ID’s must be unique. This is a problem, as you have defined your myButton style using the ID:

    #myButton {
    	background-color:#ef7c2a;
    	-moz-border-radius:5px;
    	-webkit-border-radius:5px;
    	border-radius:5px;
    	display:inline-block;
    	cursor:pointer;
    	color:#ffffff;
    	font-family: 'Oxygen', sans-serif;
    	font-size:17px;
    	padding:12px 33px;
    	text-decoration:none;
    margin-bottom:30px;
    }
    #myButton:hover {
    	background-color:#f28943;
    }
    #myButton:active {
    	position:relative;
    	top:1px;
    }
    

    This should all be changed to .myButton

    Second: If you are going to use external print buttons, please follow the instructions here:
    http://spacedonkey.de/2400/print-o-matic-external-buttons/

    If you do, you will end up creating something like:

    [vc_row][vc_column width="1/2"]<div id="coupon_two">[vc_single_image image="1782" img_size="full" alignment="center" onclick="link_image" css_animation="appear" el_class=""]</div>[vc_column_text]
    <p style="text-align: center;">
    <button id="print_coupon_two" class="printomatic myButton" data-print_target="#coupon_two">Imprimer ce coupon</button>
    [print-me id="print_coupon_two" printstyle="external"/]
    </p>
    [/vc_column_text][/vc_column]
    

    and you will find that it works on the test-coupon page.

    Thank you miles !!!!!!!
    Thank you …

    And sorry to have you bet on your mail;)

    Plugin Author Baden

    (@baden03)

    Glad it worked out.
    If you are pleased with the plugin or it’s support, consider leaving a review!
    Issue marked as resolved.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Failed in Mozilla Firefox’ is closed to new replies.