• Steve

    (@stevepalmeratwordpress)


    Hi Everyone

    I’m new to WordPress but am learning pretty fast, having just moved all my blogs from Blogger to WordPress. I’ve since added plenty of plugins and yours is the latest. I can see it’s very powerful and I’d like to get it working – but I can’t.

    I’ve been through the setup process, but If I try and add a Google Album, it pops up an error message pointing back to the setup/authentication screen – I suspect I have created an error here, somewhere.

    I get all the way through the process (Google Client ID and the Google Secret are all OK) but when it comes to the token stage, and try and get it, the token is ‘undefined’
    is that normal? Is that what is stopping it functioning?

    The screen then suggests that I use ‘Google Photos Refresh Token Getter’, but I am not seeing that option anywhere.

    Does any of this make sense? Is there any other data I can provide you with to get your excellent plugin working?

    I tried ‘re-authenticating’ but I still get ‘undefined’ for the token – and the plugin is is still unable to find any of my Albums.

    I’d appreciate any help.

    Thanks

    Steve

Viewing 15 replies - 61 through 75 (of 78 total)
  • Plugin Author Sayontan

    (@sayontan)

    Sorry – just got back from a “government office”, which, true to stereotype took much longer than it should have. Let us attempt tomorrow if you are not around right now.

    Steve

    (@stevepalmeratwordpress)

    Lucky you! Always good to meet with the ‘government’ πŸ˜‰

    Just out the door here. Yes, how about 6pm tomorrow (UK time)?

    Thanks

    Steve

    Plugin Author Sayontan

    (@sayontan)

    Hi Steve,
    I looked around a little, and while I am still clueless as to why this is working in the back-end and not on the front-end, there do appear to be some other posts about this behaviour for Google’s OAuth both on WP’s site and beyond.

    So I think one option for you would be to redo the authentication process with your own Client ID and Secret, and generate a new token.

    Steve

    (@stevepalmeratwordpress)

    Thanks Sayontan. That makes sense.

    Can you remind me of the steps to create my own Client ID and Secret? I recall there was a step-by-step guide form you somewhere here

    Appreciate your continued support!

    Steve

    Plugin Author Sayontan

    (@sayontan)

    Steve

    (@stevepalmeratwordpress)

    Thanks Sayontan

    I’m out most of today, but I’ll try and get some time to set this up. Will drop you a line in advance of tonight and let you know.

    Again, I really appreciate your help.

    Steve

    Steve

    (@stevepalmeratwordpress)

    I’m struggling here

    When I go to the ‘Create Client ID’ I’m *not* seeing ‘authorised redirect urls’…

    instead I’m seeing options for:-

    Application Homepage link
    Application Privacy Policy link
    Application Terms of Service link

    What am I doing wrong?

    Thanks

    Steve

    Steve

    (@stevepalmeratwordpress)

    Also when I try and go through the authentication stage in Photonics, I’m getting

    “401. That’s an error.

    Error: deleted_client

    The OAuth client was deleted.
    Request Details

    That’s all we know”

    Thanks

    Steve

    Steve

    (@stevepalmeratwordpress)

    Ignore previous two posts. I got round it…

    Steve

    (@stevepalmeratwordpress)

    Hi again Sayontan

    When I try and authenticate I’m now getting error messages to do with

    stevepalmertheblogger.com/wp-admin/admin.php?page=photonic-auth&source=google

    not being ‘on the authorised domain list’…

    but when I try and add it, it tells me it ‘cannot contain path’

    Can’t really go much further without this part being resolved

    Thanks

    Plugin Author Sayontan

    (@sayontan)

    I am guessing it simply needs to be stevepalmertheblogger.com for the authorized domain.

    • This reply was modified 10 months ago by Sayontan.
    Steve

    (@stevepalmeratwordpress)

    Yes, you’re right. There is also another with the login url for my WordPress backend too!

    More info once I’ve worked it through…

    Catch you later

    Steve

    (@stevepalmeratwordpress)

    Hi Sayontan

    OK back in front of the PC earlier than expected. Here is an update

    I’ve spent a few hours troubleshooting today and so you can ignore all recent posts about not having access to various ‘stuff’. Somehow, I’ve retraced my steps and managed get rid of most of the error messages! πŸ™‚

    So, having reset everything and started again from scratch, I can now get all the way through the stage of creating a display including the shortcode – which is good!

    gallery type='google' view='albums' access='all' crop_thumb='crop' title_position='below' main_size='1600' thumb_size='150' popup='hide' layout='circle']

    BUT, when I click on the option to insert, although the large google photos icon is present, when I review the Post, it’s empty and I get the following error message showing on the Post itself

    Failed to get data. Error:
    Request is missing required authentication credential. Expected OAuth 2 access token, login cookie or other valid authentication credential. See https://developers.google.com/identity/sign-in/web/devconsole-project

    So, I think we are unfortunately back where we started – frustrating for both of us ehh?!

    I’m very mindful (and grateful) of all the support you are giving me, but I am wondering now whether just to give up on it after a few more trys tonight? I’m happy to try any further suggestions you have, but maybe, I’ll give it all a break, take my vacation, and pick things up when I’m back mid-March?

    This is really stretching me – and my lack of understanding of php isn’t helping! πŸ™

    In short, if you think there’s a way of fixing it, I’m happy to ‘hang on in there’. I would really like to be able to use this excellent Plugin in future posts

    Happy to be guided by you! πŸ™‚

    Steve

    Plugin Author Sayontan

    (@sayontan)

    Considering that this thread is 5 pages long at the time of writing (it is the longest support thread I have had), I am inclined to give up.

    Let’s try a few more things:

    1. Let’s start off by disabling all your other plugins. I know you have quite a few, but since activating / disabling is an easy exercise, let’s do it to see if the conflict is between Photonic and another plugin, or between Photonic and your site’s security setup.
    2. If the above doesn’t resolve the issue, can you tell me what “machine code” is printed out when you are creating a gallery via the editor? You mentioned a few posts back that some machine code came up while building the gallery (those lines are coming due to the changes I had you make yesterday).

    If I am unable to decipher the issue based on that code, we should probably move on and try a different plugin.

    Steve

    (@stevepalmeratwordpress)

    Hi Sayontan

    OK. Give me 10 minutes or so (it’s 5.15pm here) and I’ll disable all the other plugins and see what happens.

    On a slightly more positive note – I tried using the standard wordpress ‘gallery option’ within the WordPress editor (‘add media’ -> ‘create gallery’) and in the edit screen there are some Photonic options (with the title ‘Photonic WP Gallery Settings’). The good news, no GREAT news is that I can tweak those and it seems to allow me to drop a gallery in no problem… πŸ™‚

    Anyway, back to the disabling – I’ll post the results here shortly.

    Thanks

    Steve

Viewing 15 replies - 61 through 75 (of 78 total)
  • The topic ‘Failed Authentication (sort of)’ is closed to new replies.