Support » How-To and Troubleshooting » Failed attempt to restore 1.2

Failed attempt to restore 1.2

  • HELP! I killed my blog. I wanted to upgrade from 1.2 to 1.5 and I read all the information regarding update installation and followed the directions, including creating a back up file of my data base.
    The install of 1.5 didn’t work, so I followed the instructions to restore the previous data base….
    It’s not working either… I get this fatal error message when I try…..

    Server: localhost Database: azjadec_wrdp1

    Fatal error: Maximum execution time of 300 seconds exceeded in /usr/local/cpanel/base/3rdparty/phpMyAdmin/libraries/string.lib.php on line 79

    I am in tears! I don’t know anything about this stuff and I don’t know what possesed me to think I could even upgrade! I am so stupid. Is there anything I can do or is my blog just gone forever??
    Please help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The error you got was just because it was taking too long for MySQL to restore your database file and your server timed out. I don’t know if you can change the timeout setting yourself, so you might look into the matter with your host.

    And what was the problem with your upgrade?

    I don’t know what the problem was. I got all kinds of weird error messages that covered an entire page, over lapping one another. When I tried to get to my blog, it was just a blank page.

    I don’t know where to even begin to attempt to change the timeout setting myself….I suppose I’ll email my host regarding that. If that is changed, will the restore then take place?

    Thank you for your reply. I am devistated I ruined everything…..

    What the directions called for was backing up not just your database but all the files and directory structure of your Weblog. You could do that using an ftp program or, if your Web host’s setup is like mine, by going to cPanel and using the backup utility provided. That backs up your whole Web space.

    The fact that I did that saved my blog after an attempted upgrade from 1.2 to 1.5 didn’t work out.

    If all you have backed up is your database, ask your Web host if there’s any chance your Web space can be backed up from their end. I would be surprised if they cannot do this for you.

    If that doesn’t work out and if your blog wasn’t heavily modified, you should be able to do a fresh install to the same location (after clearing out anything there from the upgrade attempt). Then hook into the database and you’re back in business.

    Then, periodically, go to your cPanel and use the backup tool.

    Good luck.

    Ugh! Regarding the previous entry, a correction:

    If all you have backed up is your database, ask your Web host if there’s any chance your Web space can be restored from their end. I would be surprised if they cannot do this for you.



    If you saved your database successfully, then you have all of your posts and comments. All you need to do is restore the database and then upload all of your WordPress files. You also need to create the necessary wp-config.php file to connect to your database.

    You said you did a backup of the database, so all you may have lost is simply the site design if you did any tweaking on your own.

    Relax, take a breath. The world has not ended. There are people around to help and information for you to read through.

    http://www.tamba2.org.uk/wordpress/backup/ will walk you through restoring your database. As has been mentioned, you could also enlist the help of your host as well.

    I got it correct on my third try. So it is possible.

    I backed up using the save under phpmyadmin to my home computer’s hard drive, then upgraded my fantastico install of 1.2 to 1.5 manually.

    I probably mistepped a few times, but I finally got it to work.

    Before I did it the third time in one night, I printed out the instructions for upgrade. Then manually checked them off as I did each step. That one worked.

    Just letting you know that the upgrade will work eventually.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Failed attempt to restore 1.2’ is closed to new replies.