WordPress.org

Support

Support » Installation » [Resolved] Failed 2.6.1 Fresh install

[Resolved] Failed 2.6.1 Fresh install

  • WordPress database error Table 'wordpress.wp_options' doesn't exist for query INSERT INTO wp_options (option_name, option_value, autoload) VALUES ('cron', 'a:2:{i:1219846190;a:1:{s:17:\"wp_update_plugins\";a:1:{s:32:\"40cd750bba9870f18aada2478b24840a\";a:3:{s:8:\"schedule\";s:10:\"twicedaily\";s:4:\"args\";a:0:{}s:8:\"interval\";i:43200;}}}s:7:\"version\";i:2;}', 'yes') made by add_option
    WordPress database error Table 'wordpress.wp_options' doesn't exist for query INSERT INTO wp_options (option_name, option_value, autoload) VALUES ('auth_salt', 'vRSk1hQEvz0#', 'yes') made by add_option

    That’s the error msg when we go to the install.php page

    And if I look at the database, it’s empty. So it doesn’t seem to have created any tables whatsoever.

    Where are the SQL scripts kept?? Can we do it manually?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’m having the same issue on a IIS7 Box
    PHP Version 5.2.6
    Server API CGI/FastCGI

    Looks like schema.php is the code page that creates the database but never runs before is calls the insert statement!

    The database was never created does anybody have any ideas?

    Is there a prepared SQL Schema to create the database manually?

    The previous 2 post I meant “Tables” the database is already set up!

    I had the same error with the wp_options table.

    I was able to manually create the table with the following command in mySQL.

    CREATE TABLE wp_options ( option_id bigint(20) NOT NULL auto_increment, blog_id int(11) NOT NULL default '0', option_name varchar(64) NOT NULL default '', option_value longtext NOT NULL, autoload enum('yes','no') NOT NULL default 'yes', PRIMARY KEY (option_id,blog_id,option_name), KEY option_name (option_name) ) DEFAULT CHARACTER SET utf8;

    Once i did that… i was able to complete the installation process.

    I hope it works as well for you.

    By the way I am running:

    IIS7 on Windows 2008
    PHP Version 5.2.5 (with FastCGI)
    mySQL on a separate box

    I had manually created the mySQL database and user before I attempted to run the install.php file

    oh wow the installation went through!
    Thanks heaps skot123! 😀

    I have the same issue. A fresh install on IIS7 using PHP with FastCGI

    I have a different error – but also no database tables, so I ran the sql posted by skot123 and still no change (although I do now have tables in my database).

    My error when I go to http://www.mydomain.com/wp-admin/install.php is:

    ‘.__(‘Already Installed’).’
    ‘.__(‘You appear to have already installed WordPress. To reinstall please clear your old database tables first.’).’

    ‘);} switch($step) { case 0: case 1: // in case people are directly linking to this display_header(); ?>
    ReadMe documentation at your leisure. Otherwise, just fill in the information below and you\’ll be on your way to using the most extendable and powerful personal publishing platform in the world.’), ‘../readme.html’); ?>

    error) ) wp_die($wpdb->error->get_error_message()); display_header(); // Fill in the data we gathered $weblog_title = stripslashes($_POST[‘weblog_title’]); $admin_email = stripslashes($_POST[‘admin_email’]); $public = (int) $_POST[‘blog_public’]; // check e-mail address if (empty($admin_email)) { // TODO: poka-yoke die(‘
    ‘.__(“ERROR: you must provide an e-mail address.”).’

    ‘); } else if (!is_email($admin_email)) { // TODO: poka-yoke die(‘
    ‘.__(‘ERROR: that isn’t a valid e-mail address. E-mail addresses look like: username@example.com‘).’

    ‘); } $wpdb->show_errors(); $result = wp_install($weblog_title, ‘admin’, $admin_email, $public); extract($result, EXTR_SKIP); ?>

    admin

    Note that password carefully! It is a random password that was generated just for you.’).’

    ‘; ?>

    ** I’ve used a fresh database, fresh user, no data in the database, and it’s still not working – and my wp-config file has the correct settings…any help would be most appreciated. Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Failed 2.6.1 Fresh install’ is closed to new replies.