WordPress.org

Forums

Duplicator
[resolved] Root Directory problem (20 posts)

  1. kittersa
    Member
    Posted 1 year ago #

    I am receiving the following message:

    Root Directory Fail
    Path: /home/content/43/11022843/html
    [Pass] Is Writable
    [Fail] Contains only one zip file.
    Result = Too many zip files in directory
    Manual extraction still requires zip file

    I do have a bunch of files in the main directory, one being a zip file of resource files. Can I delete the Resource zip (hopefully this fixes the root Directory Error) then re-install that zip folder after the new site has launched? Or do you have any other ideas?

    I was trying all day yesterday and struggling again today, I really need the site launched before the weekend.

    Really appreciate the help and from what I hear the plugin is great,

    Cheers,

    http://wordpress.org/extend/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey kittersa,

    If you can give the Developer Version a try it may have your fixes for the issue you're seeing. The issue is that the is writable pass probably shouldn't be passing as there was a bug in that version. The very latest version can be found by following these instructions:

    -> Browse to http://wordpress.org/extend/plugins/duplicator/developers/
    -> Look for the section "Other Versions"
    -> Click on "Development Version" and download the zip plugin file
    -> Uninstall your current version and install this one
    -> Note: The version number might still be the same but the source code is different.

    Let me know if this solves your issue...

    Thanks

  3. kittersa
    Member
    Posted 1 year ago #

    I installed the new version, downloaded and uploaded the Installer.php and ...package.zip and receiving the following message:

    Path: /home/content/43/11022843/html
    [Pass] Is Writable by PHP
    [Fail] Contains only one zip file
    Result = Too many zip files in directory
    Note: Manual extraction still requires the package.zip file

  4. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey kittersa,

    My bad, I overlooked that you mentioned multiple zip files... Yes you will need to only have one zip file in the same directory as the installer.php file. It is recommended that you only have these two files as it will overwrite other files/folders with the same name when it extracts the zip file...

    Sorry for the confusion...

  5. kittersa
    Member
    Posted 1 year ago #

    Hey,

    No problem, do you recommend making a new subdirectory, lets say '2013'. Then put the Installer and Package files inside to get the site going?

    The problem with that is the site URL will then be: mysite.com/2013. Can I move the site afterwards so it doesn't have 2013 at the end? Hope that makes sense.

    Unless there is an easier way of doing this?

    Cheers,

  6. kittersa
    Member
    Posted 1 year ago #

    I have just made a 2013 directory and uploaded the package and installer files, this let me get past the original error message. Now I am receiving a new error message:

    DATABASE CONNECTION FAILED!
    Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

    Common Connection Issues:
    - Double check case sensitive values 'User', 'Password' & the 'Database Name'
    - Validate the database and database user exist on this server
    - Check if the database user has the correct permission levels to this database
    - The host 'localhost' may not work on all hosting providers
    - Contact your hosting provider for the exact required parameters
    - See the 'Database Setup Help' section on step 1 for more details
    - Visit the online resources 'Common FAQ page'

    --
    Hosting: Go Daddy
    File Permissions for the Installer and Package.zip: 777
    DB Direct Access: Yes

  7. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey kittersa,

    Here is a helpful section on the FAQs page:
    -> Browse To: http://lifeinthegrid.com/duplicator-faq/
    -> Find Section: "2. Installer"
    -> See Area/Question: "I can't connect to my Database what should I do?"

    You will most likely need to contact GD to get the exact settings...

  8. kittersa
    Member
    Posted 1 year ago #

    Hello,

    I contacted Go Daddy and received this email:

    Thank you for contacting Online Support. I understand you are trying to use Duplicator on your hosting. In reviewing your site we are currently unable to duplicate the issue you are experiencing. I have also tested your hosting plan and am able to confirm that there are no known issues that would affect your databases or the direct connection.

    We are unable to support third party application issues and we do not support the inner functionality of this program. If you are having difficulty using a third party product, we can help troubleshoot that process to the point that we find that the issue lies entirely within the configuration of that product. If you believe the issue is caused by something within our system please reply with as much pertinent information as possible and we will further review the issue.
    ---

    I don't mind giving you my login details, installer and package.zip via email, you can probably solve the problem instantly. I needed to have the website launched last week, I have spent 4 days trying to use this plugin because I was told if was the quickest way.

    I look forward to hearing from you,

  9. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey kitersa,

    I don't think there is really anything I can do from my end. The code is pretty much the same for every server. Its using standard PHP mysql connection methods. What are you using for the hostname when you try to connect? Did GD give you something other than localhost to use? Did they say you need to use a port number?

    Did you visit this article?
    http://support.godaddy.com/help/article/3323/locating-your-database-connection-strings

    Did you point GD techs at the installer.php file and have them enter in the DB credentials?

  10. kittersa
    Member
    Posted 1 year ago #

    Go Daddy support is pretty pathetic, they just keep telling me to contact you. They haven't mentioned anything about a port number.

    Host: localhost
    Database Name: optinet.db.11022843.hostedresource.com

  11. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    If you want to submit a help ticket I can look at it for you...

    Cheers~

  12. kittersa
    Member
    Posted 1 year ago #

    I've made progress this morning, I managed to get the Test Connection successful. Go Daddy finally decided to help me with the Host name.

    Everything appeared to install fine until I go on the site, I'm getting a white screen and the following message:

    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /home/content/43/11022843/html/index.php on line 17

    Fatal error: require() [function.require]: Failed opening required './wp-blog-header.php' (include_path='.:/usr/local/php5_3/lib/php') in /home/content/43/11022843/html/index.php on line 17

    Before I could finish the Duplicator I got a message saying a WordPress index file already exists, therefore I deleted all the WordPress files I installed yesterday - then continued with the Duplicator.

  13. kittersa
    Member
    Posted 1 year ago #

    Trying to re-install and noticed:

    Install Error: The Duplicator only works with an EMPTY database. Enable the "Table Removal" checkbox to delete all tables and proceed with installation. Please backup all your data before proceeding!

    What should I be 'backing-up'?

  14. kittersa
    Member
    Posted 1 year ago #

    Even with the Table Removal selected the website still reads the Warning: require... message (posted above). Incredibly stressful

  15. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    It sounds like you need some help. Did you already submit a help ticket?

  16. kittersa
    Member
    Posted 1 year ago #

    Yes, I sent one yesterday. I got a response this morning, but I haven't heard anything back about the new problem.

    Cheers,

  17. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Alright I see it...

    Thxs

  18. hartmutnz
    Member
    Posted 1 year ago #

    I also had similar problems installing into the root directory. Now I managed to install into a folder: new
    Now how do I move that installation to the root folder without destroying the site?
    Should I use the standard WP procedure re: moving site or is there an easier way?
    Please advise.

  19. hartmutnz
    Member
    Posted 1 year ago #

    Kittersa: Had similar problems so I created a new database for each new try.. that worked!
    Then you could eventually delete the older unused databases if you want.
    The database path is shown in the MySql Datapabe panel on top usually.. copy that to the location at install settings where it says: localhost.
    Other than that you need to delete all files from your new folder exxept the installer.php and the data.zip file

  20. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey hartmutnz,

    I would use the standard WP procedure. However the underlying issue with kittersa was that they had a setting on the MAC that would automatically create a folder within the package.zip file that was named the same as the package. This causes issues with the Duplicator...

    The package.zip file should at its root have folders like wp-admin, wp-content, wp-config.php etc... So MAC systems will create a folder at the very top level of the zip file named the same as the package and this causes issues when the Duplicator goes to extract the files. I think it might even be an issue with Safari.

    I had another user post this:

    In MAC systems you can automatically unzip files when download is complete on some browsers. This will cause issues with the Duplicator because the installer looks for a zipped up package file. To turn this feature off in browsers like Safari please follow these steps: Go to: Preferences > General > Open Safe files after downloading -- leave this box unchecked.

    I'm not sure if your using a MAC but that is the issue kittersa had...

    Beyond that you should be able to deploy to the root directory, you might have to work with permissions on the server or double check with GD...

    Hope that helps!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic