Support » Fixing WordPress » Facing this error after updating WordPress to 4.3

  • Resolved WPtesting

    (@wptesting)


    I’m getting a Fatal error on Add New Post page after updating to WP 4.3.

    Every time I’m trying to edit my post URL, add tags, I’m getting this error:

    Fatal error: Allowed memory size of 94371840 bytes exhausted (tried to allocate 2573294 bytes) in /home/root/blog.com/wp-includes/functions.php on line 384

    How to fix this??

    Thanks.

Viewing 15 replies - 1 through 15 (of 25 total)
  • Try reinstalling WordPress 4.3 and deactivate all of your plugins.

    How to reinstall 4.3? It’s on my live site!!!

    I have deactivated all my plugins but facing the same problem!

    You just go to the dashboard > updates section in your website and click the re-install button.

    Hi again!

    I have re installed it, facing the same error!!! 🙁

    Try increasing the memory available to PHP:
    http://wordpress.org/support/topic/253495#post-1017842

    Hi Matthew,

    Thanks for your time,

    I have an embedded theme plugin, which was creating the error. But after fixing the theme, I’ve noticed that most of my essential plugins aren’t compatible with 4.3 yet.

    So, I have downgraded my WP to 4.2.4 for now. 🙂

    I experience exactly the same issue (memory exhausted) since the upgrade, although we have a memory limit of 128M, what should be enough.

    Doing a quick search I find a large number of websites with the same error.
    Do you have suggestions how to find the specific function which causes the error? (other than line 384 in wp-includes/functions.php)
    The error fortunately only shows up in the backend, every call to admin-ajax.php results in a 500 error.

    Same issue on one of my site . Seo Redirection plugin that captures 404 error says some of my users also faced it on the front end but i couldnt replicate it by myself . Tried increasing php limit by 145 MB , but still error on line 384

    Didn’t you find any solutions for that? Our news website has the same problem and is in a bad situation because of this problem.

    Have you tried:
    – Flushing any caching plugins you might be running, as well as server and/or browser caches.
    – deactivating ALL (yes all) plugins temporarily to see if this resolves the problem (plugin functions can interfere). If this works, re-activate them individually (one-by-one) to find the problematic plugin(s).
    – If you can’t get into your admin dashboard, try resetting the plugins folder by FTP. Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder (if you have created such folder). The easiest way is to rename that folder to mu-plugins-old.
    – switching to the unedited default Twenty Fifteen theme for a moment using the WP dashboard to rule out any theme-specific issue (theme functions can interfere like plugins). If you don’t have access to your admin area, use FTP , or your web-host’s cPanel or whatever file management application your host provides. Navigate to /wp-content/themes/ and switch to the default theme by renaming your current theme’s folder by adding “-old” to the end of the folder name. Alternately, you can remove other themes except the default theme. That will force your site to use it.
    – If all the above steps do not resolve the issue, then try MANUAL updating. Download a fresh copy of the WordPress .zip file to your computer, unzip it, and use that to copy up all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory. You may need to delete the old copies of files & folder on your server before uploading the new ones. Read the Manual Update directions first.
    -If you haven’t already done, always backup everything (including your database) before doing any actions, just in case something really goes wrong.

    I know that some of these may not apple but I would try as many as you possibly can.

    This bug turned really nasty, resulting in database connection failures.
    I think this is strongly related to this issue, as we had a huge list of cronjobs: https://core.trac.wordpress.org/ticket/33423
    Check in phpmyadmin if the table wp_options is a decent size (< 1mb) and if not try to clear the option named ‘cron’.
    I’ve manually edited taxonomy.php l4448 to correctly create the cronjobs, now waiting for update 4.3.1 to fix this.

    HI, same issue for me.

    I can’t edit or change my Thesis template. When i try to add an element i have this ugly error message.

    I don’t want deactivate plugins one by one, i don’t want reinstall WordPress. I don’t have free time for that.

    It’s a bug of WordPress and we need a fix urgent. If you “googled” this:
    Fatal error: Allowed memory size of functions.php on line 384
    you will see a lot of sites with this error. It’s horrible.

    Thanks.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    I don’t want deactivate plugins one by one, i don’t want reinstall WordPress. I don’t have free time for that.

    I’m sorry but there is literally no other way to debug WordPress.

    Functions.php is a file in your theme. It’s likely that Thesis needs an update/fix.

    Sorry Ipstenu, i think is not a Thesis problem.

    You can search in Google : Fatal error: Allowed memory size of functions.php on line 384 and filter this search by “last week” and you’ll see a lot of pages with this error in the content. I think all these pages not use Thesis. It’s a WordPress bug. i don’t know if this bug is reported.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    That’s a very standard error. By the time you get to /wp-includes/functions.php PHP is out of memory. You need to figure out what is hogging all of the memory, it could very well be Thesis, or just increase PHP’s memory allocation.

    If you’re seeing this error either suddenly (no specific task was done to cause the error) or frequently, try deactivating all plugins to rule-out a plugin-specific issue and try switching themes to rule-out a theme-specific issue.

    Otherwise, here are three ways to increase PHP’s memory allocation:

    1. If you can edit or override the system php.ini file, increase the memory limit. For example, memory_limit = 128M

    2. If you cannot edit or override the system php.ini file, add php_value memory_limit 128M to your .htaccess file.

    3. If neither of these work, it’s time to ask your hosting provider to temporarily increase PHP’s memory allocation on your account. Keep in mind that most decent hosting providers allocate 32 MB to PHP under each account, and most decent hosting providers allow users to temporarily increase the memory allocation. If your hosting provider won’t accommodate you, perhaps it’s time to find a new hosting provider.

    (in the above examples, the limit is set to 128MB)

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Facing this error after updating WordPress to 4.3’ is closed to new replies.