WordPress.org

Forums

Facebook thumbnail incorrect- featured image (4 posts)

  1. tellmeatale
    Member
    Posted 1 year ago #

    Hi,

    I'm having issues with my websites 'featured image'. When I try and post a link from some of my website pages onto my facebook the thumbnail is not my featured image. For example when http://www.frozenlighttheatre.org is posted on facebook it is a featured image of 'the grid' a previous wordpress theme I was using (which has been uninstalled). I put in an easy facebook share plugin to try and sort the issue and tested it on the picture of a peach as a default option for pages without fetaured images. However I recently changed the peach image to one I actually wanted and its not working (e.g http://frozenlighttheatre.com/contact-us/) Then on other pages the featured image does come up (e.g http://frozenlighttheatre.com/our-audience/). I cant work out if this is a wordpress issue or a facebook issue (is their cache not cleared?). Feeling very confused about it! Any ideas would be hugely appreciated. Thanks.

  2. Simon Vandereecken
    Member
    Posted 1 year ago #

    Facebook has a great tool to test URL, you can find it here : https://developers.facebook.com/tools/debug it'll show you exactly what's happening and the errors it encounters. Note also that when changing things like that Facebook isn't the quickest to refresh its caches unfortunately :/

  3. tellmeatale
    Member
    Posted 1 year ago #

    Thank you so much, the facebook debugging worked! My hero!

  4. Simon Vandereecken
    Member
    Posted 1 year ago #

    You're welcome :) It helped me lot of times too ;)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.