Support » Plugin: Jetpack by WordPress.com » Facebook Sharing Image does not Display

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Since you’ve activated WordPress SEO by Yoast on that site, Jetpack does not add any Open Graph tags to your posts anymore; this is handled by your SEO plugin, and you can customize it by checking your SEO Social settings.

    These tags are then used by Facebook to populate the Title, description, and image fields of the URLs you share on Facebook.

    I have the same issue, i do not have YOAST

    (This concerns autoshare to facebook which generates thumb, but when people try to share thumbs will not work at all!)

    Hotlink on server is disabled, htaccess is stock WP install

    I’m having a similar problem, also with no SEO plugins. Clicking the Facebook button brings up a box with the URL in the comments, the URL as the post title, and the URL with a string of letters and numbers inserted into it as the description, no image option.

    Here for example:
    http://www.gcpvd.org/2013/03/02/gc-photos-96/

    It has been a few days, I don’t know if it is a Facebook update, a Jetpack update…

    Anyone have any thoughts?

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @waffenss You have posted in multiple threads about your problem. Could you start your own thread, and give us a few examples of the posts where you experienced the issue?

    Thank you.

    @jef I solved the issue by clearing Facebook’s cache for that URL:
    http://i.wpne.ws/NJuE

    You can clear Facebook’s cache by entering the URL in Facebook debugger, here:
    https://developers.facebook.com/tools/debug/

    If you experience issues with other URLs, you’ll want to enter them all in that form.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Facebook Sharing Image does not Display’ is closed to new replies.