Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author JS Morisset

    (@jsmoriss)


    Yeah, I’ve seen this issue once in a while on some (slow) websites. The Facebook cache and crawler are pretty good (especially compared to Pinterest and LinkedIn), but it can have issues on occasion – especially when Facebook is making changes to their standards / back-end.

    Make sure your page load is under 2-3 seconds. Anything above that is an issue (can lead to timeouts on the crawlers). Also make sure your CDN is fetching / pre-fetching correctly and isn’t introducing long delays on new content (images).

    If you’re using pre-existing images from the Media Library, that pre-date your installation of NGFB Open Graph+, and you’re using a shared hosting with slow disk I/O, you could try regenerating the image sizes (there are lots of plugins available to do this).

    js.

    ewoutdegraaf

    (@ewoutdegraaf)


    I don’t know if that is the problem. Yes, the hosting is shared, but the site loads in less then one second, and sometimes even faster. And, if i try the same API call several times, the problem stays the same – you should expect that the problem would go up and down with load times. But it is very persistent – until i load the site in the facebook debug API.

    Plugin Author JS Morisset

    (@jsmoriss)


    How do you share the URL on Facebook? A button on the site, a button in the browser, paste the URL in Facebook?

    Try pasting the URL directly in a Facebook post, and see if you get the same issue.

    If you’re using a button, try a different browser.

    js.

    Plugin Author JS Morisset

    (@jsmoriss)


    Let me know if you’re still having issue, or I should close this thread.

    Thanks,

    js.

    Plugin Author JS Morisset

    (@jsmoriss)


    Closing the thread.

    js.

    ewoutdegraaf

    (@ewoutdegraaf)


    When i use the facebook share option on my timeline, exactly the same happens.

    When i share the URL, it only shows the URL and the website.

    Then, when i first debug the page, and then share the URL, it shows the image and an excerpt of the site.

    Website is http://www.daanslife.nl

    Plugin Author JS Morisset

    (@jsmoriss)


    Disable the shareaholic plugin and see if that solves your problem.

    js.

    ewoutdegraaf

    (@ewoutdegraaf)


    Do you have an alternative plugin that shows sharing buttons and DOES work?

    Shareaholic

    (@shareaholic)


    This article may help:
    http://support.shareaholic.com/hc/en-us/articles/200471606-Troubleshooting-Facebook-Issues

    You can disable Shareaholic inserting Open Graph tags (option is in the Advanced Settings menu). Make sure you’re running version 7+ of the plugin.

    ewoutdegraaf

    (@ewoutdegraaf)


    I have disabled the Shareaholic Open Graph option. Version is 7.0.8.0, i am confident that this will solve my problem.

    Many thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Facebook sharing api malfunction’ is closed to new replies.