Support » Plugins and Hacks » Jetpack by WordPress.com » Facebook Share via Publicize is not working?

Facebook Share via Publicize is not working?

  • I posted this question last night, but cant seem to find the post now?

    My blog posts are not posting to FB. I enabled the “share” option and connected my fb account but its still not working. I was able to get one post to share over after I uninstalled the fb ap and re-installed … but nothing since?

    I have a couple of posts scheduled and one post shows it is going to share and the other post is not going to share.

    I have gone into edit multiple times and clicked the box and then update, but its not holding and the box unchecks itself. Why is the Publicize working for some posts and not others?

    Thanks ~ HoopersChallenge.com


Viewing 15 replies - 16 through 30 (of 41 total)
  • Plugin Author Jeremy Herve


    Could you check your app settings on Facebook, and see if the WordPress.com app is listed here?

    If not, you will want to reset the connection once again.

    Let me know if this helps!

    Hi Jeremy, we have the same problem but only related to Facebook.

    Publicize module is working correctly in Twitter, Linkedin and Tumblr.

    We’ve already tried to deactivate all other plugins and deactivated/re-activated JetPack several times.

    We’ve tried procedure described in:

    …twice but the problem remains.

    99% of the time we have to publicize in FB manually.

    What’s wrong?
    What can we do?

    Our URL: http://www.materiaincognita.com.br

    We’d like to thank you in advance!


    Plugin Author Jeremy Herve


    @marcos I checked the status of your Facebook connection, and your Facebook Token doesn’t seem to be valid anymore. Could you try to go through the steps described here, once again?

    It’s important that you remove the app from your Facebook account to reset the connection.

    Also, I stopped using the schedule feature since those were the ones last week not posting over, but now even the ones that I post immediately are not posting to fb.

    Any other suggestions?

    Nope, still there — see image:http://hooperschallenge.com/wp-content/uploads/2013/02/app-copy.jpg

    I also just uninstalled and re-installed so now it says my last log in was less than 24 hours … just made a post, and it didnt go to FB. Had to manually post over.

    Plugin Author Jeremy Herve


    Alright, thanks for the screenshot. I’m not sure what’s wrong with your connection. I have forwarded the issue to our Publicize expert, and we’ll get back to you as soon as we can address the issue!

    I thought the problem was fixed with the plug in update, but unfortunatly, my “scheduled” posts are still not being posting over to FB. The posts I publish immediately are working … just not scheduled.


    Nope still not fixed? I published a post this am that was posted to fb, but a couple hours later I published 2 more (not using the schedule) and neither of them posted over to fb??

    @jeremy and hooperschallenge, now it’s all right.

    Since 2.2 update of JetPack plugin, ‘Publicize module’ is working fine with Facebook, Twitter, Linkedin and Tumblr, for immediate postings or for scheduled postings.

    Sometimes some posts take a longer time to publicize than others (1~2 minutes) but I think it depends on the traffic of that moment.

    Take a look at: https://www.facebook.com/materia.incognita

    Best regards to all of you,

    [sig moderated as per the Forum Rules]

    Yes but Facebook thumbnails will not post Marcos as of lately need to find out if its Jetpack update or facebook API, click share on one of your non Images, a post published from your blog.

    Is this still being worked on? Looks like none of my posts are publishing to fb, even the immediate postings I am making. I deleted the app again yesterday and reinstalled, but it still doesnt work…

    Plugin Author Jeremy Herve


    @hooperschallenge I didn’t forget about you. Unfortunately, we haven’t found anything that could cause the problem on your site, but we’re looking into it! I will keep you posted as soon as we have results.

    In our last 30 posts, 2 of them didn’t publish automatically in Facebook.
    It’s not a BIG problem for me. This kind of thing could be caused by high traffic in FB or due to my broadband connection at the moment of publishing a post, I don’t know…

    Sometimes, the automatic publishing don’t grab the correct image from the post but it’s rare.

    Anyway, the ‘Publicize module’ is working much better than previous version.

    I have never managed to get the Jetpack sharing with Facebook or Twitter. In fact I’ve given up and am using something else to do it.

    @twonk, what are you using?

Viewing 15 replies - 16 through 30 (of 41 total)
  • The topic ‘Facebook Share via Publicize is not working?’ is closed to new replies.
Skip to toolbar