WordPress.org

Support

Support » Plugins and Hacks » NertWorks All in One Social Share Tools » [Resolved] Facebook share issues

[Resolved] Facebook share issues

Viewing 15 replies - 1 through 15 (of 37 total)
  • Plugin Author nertworks

    @nertworks

    Do these posts have any images in them?

    Plugin Author nertworks

    @nertworks

    You either need to set a featured image for that post. Otherwise the plugin or Facebook does not know where to get the images from.

    You can also enable the Image Meta Genie on my Plugin and it’ll automatically look for images in the post or page that you are sharing. If it doesn’t find one it looks for a header logo. If non of that turns up, it shows a gray box.

    Yes all of my posts are supported with pictures and some with youtube vids. I have Image Meta Genie turned on and it still is not pulling any picture, just a gray box. I am wondering if Aesthete theme is unsupported, that is the theme I am using and I have now tried about 10 plugins to get social sharing up on my website and none of them work, I have even tried running them with another open graphing plugin running as well and nothing seems to work. If anyone has had the same thing happen or knows how to correct this I would certainly appreciate the help, thank you.
    JW

    Plugin Author nertworks

    @nertworks

    Make sure that you have set Aesthete to support Featured images.

    put this in your functions.php file

    add_theme_support( ‘post-thumbnails’ );

    Can you elaborate on where to find the functions .php file. I really opologize for being half numb when it comes to wordpress. Thanks again,
    JW

    dashboard/appearance/editor/functions – core.php
    This is what I found for functions, is this where I should put
    add_theme_support( ‘post-thumbnails’ ); ?

    I think I found it! now where to add it or does it matter?

    Plugin Author nertworks

    @nertworks

    shouldn’t. Just make sure it’s not inside another function.

    http://www.jwflyfishing.com
    Ok I put the code in functions.php and now when you click on facebook link on pg 1 of website you have three choices of photos, however they do not come from the article you are trying to share. On pg 2 of website all share buttons are still getting gray box. Any other ideas? Thank you for all your help, I surely appreciated it.
    JW

    Plugin Author nertworks

    @nertworks

    page 2 just needs an image in the content. Then you’ll be good to go.

    Plugin Author nertworks

    @nertworks

    cool site. I love fishing.

    Thanks again for your continued support, pg two has 6 images and one youtube video. Do you have any idea why its not pulling one of them in?

    I still am not able to get plugin to pull in any of my youtube videos so you can see a preview of the video. The previews that are working are the same 3 images and not article specific images. Does anyone know why? Thanks for your continued help, this is what makes WordPress so awesome, help is only a few key strokes away.
    JW

    Plugin Author nertworks

    @nertworks

    So you were able to get Featured Images to work? If that’s the case. You need to install something called Auto Featured Image. It helps with stuff like this a lot. It should work with Youtube videos and images.

    Plugin Author nertworks

    @nertworks

    Also I just put another feature in this plugin. If you’ll wait just a minute I’m about to upload it. It should automatically get the images from your pages as well.

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘[Resolved] Facebook share issues’ is closed to new replies.
Skip to toolbar