• Resolved codifex

    (@codifex)


    I am using version 4.2.1 of the plugin.

    Today I saw that the share count on the Facebook button is missing. In the plugin’s status tab an error is shown for Facebook including this text (example.org is just am example):

    {"id":"https:\/\/example.org\/de"}

    Share counts are enabled for Facebook. The URL above is the WordPress instance’s siteurl (in a MultiSite environment)

    How to determine the reason for the error and how to fix it?

    Thank you in advance for any advice!

    https://wordpress.org/plugins/shariff/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hey there,

    sorry – no solution here, just the same problems:

    Multisite, exact same error on the status tab. Curiously, the Facebook sharecount is displayed in the frontend…

    Thanks for any advice!

    Cheers

    Having the same problem. Interesstingly, older posts are still showing the count.

    Plugin Author Jan-Peter

    (@starguide)

    Hi there,

    sorry for the delay. I’ve been sick for the last week and still am for the most part. Unfortunately I cannot replicate the issue yet on any of my installations. So please post a link to your affected sites so I can take a look at it and test the Facebook response myself.

    Thanks for your help in this matter.

    JP

    Thread Starter codifex

    (@codifex)

    Here is some more information (domain replaced by example.org, timestamp replaced by #):

    Call: https://example.org/de/wp-json/shariff/v1/share_counts?url=https%3A%2F%2Fexample.org%2Fde%2F&services=facebook%7Cgoogleplus&timestamp=#

    Content of the resulting JSON file:

    {"googleplus":0,"timestamp":#,"url":"https:\/\/example.org\/de\/","updated":"1"}

    Facebook is missing, although it has been requested.

    Kindly let me know if you need any further information. Thank you in advance for any advice.

    The problem occurs in both multi-site installs and single-site installs of WordPress.

    • This reply was modified 7 years, 10 months ago by codifex.
    Plugin Author Jan-Peter

    (@starguide)

    Which WordPress version are you using? And you are sure that you are using our plugin in version 4.2.1? Because Facebook no longer works in < 4.2.1. Oh and one easy thing: Please deactivate and reactive our plugin once via the WordPress plugin menu in order to empty the cache, just in case.

    Since I’m not able to replicate the issue on any of my installations (multisite and normal) I’ll need to figure out, what is special about your server or domain that it behaves differently to other installations.

    Since you don’t want to mention your domain, could you please check the response of this request (of course replace example.org with your domain):

    https://graph.facebook.com/?id=https://www.example.org

    Normally it should look something like this:

    
    {
       "og_object": {
          "id": "753226801455332",
          "description": "Immer auf der Suche nach neuen L\u00f6sungen.",
          "title": "JP|LAMBECK",
          "type": "website",
          "updated_time": "2016-05-12T20:08:38+0000"
       },
       "share": {
          "comment_count": 0,
          "share_count": 0
       },
       "id": "https://www.jplambeck.de"
    }
    

    Cheers,
    JP

    Thread Starter codifex

    (@codifex)

    I think I have tracked down the problem:

    When performing the check

    https://graph.facebook.com/?id=https://www.example.org

    for my domain, the resulting JSON document is just

    {
       "id": "https://www.example.org"
    }

    Then I checked the page using Facebook’s Sharing Debugger. It reported that the page has not yet been shared on Facebook. Then I fetched the scraping information.

    After doing that the returned JSON looks similiar to the sample you posted above and the share button for this specific page shows 0. In addition, the error in the plugin’s “Status” page disappears if this has been done for the WordPress site’s site URL.

    However, the problem persists for any page which has not yet been shared on Facebook. Facebook’s Graph API returns the ID only and the plugin seems to treat this as an error and consequently does not show the count.

    I am not sure if Facebook’s behavior is “by design” or if it has been changed recently.

    By the way, I am using WordPress 4.6 with version 4.2.1 of the plugin.

    Thank you for your effort!

    Hey JP,

    maybe a hint for tracking the error down: when checking the status for the first site of the multisite network , the facebook status is “ok”. Only for every “child”-site (or whatever you want to call it) the error message is displayed (we are using subfolders, not subdomains, for the multisite network).

    Still: in the frontend the (facebook) counts are displayed (there is a problem with the twitter count – other issue).

    Regards,
    Joerg

    • This reply was modified 7 years, 10 months ago by Joerg Gebauer.
    Plugin Author Jan-Peter

    (@starguide)

    Please update to version 4.3.0 and let me know, if you still encounter any issues.

    Thread Starter codifex

    (@codifex)

    Problem solved (share count 0 shown correctly for pages not yet known to Facebook, no error shown in the status tab). Thank you very much for the fix.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Facebook share count not shown’ is closed to new replies.