Support » Plugin: WP Facebook Open Graph protocol » facebook share button

  • Resolved wlmweb

    (@wlmweb)


    Hello, sorry! I’m having trouble with this plugin in the share of the Facebook button! The button will not start the highlighted image, put all settings Plugin Facebook Open Graph protocol plugin v2.0.13, but the share button from Facebook, takes the image that is set to when no highlighted image in the post! The url of my site is http://www.baudorock.net. They have guided me to check the CSS of my site, but do not know where to put the codes and not what they are. Thanks if you can help!

    Wagner Moraes

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Chuck Reynolds

    (@ryno267)

    First problem:
    You have this in your code:
    <meta name='robots' content='noindex,follow' />
    So you’re telling all robots to NOT index your content… that’ll mess w/ FB.

    Second problem:
    Your admin ID and app ID are messed up. I see this in your code:

    <meta property="fb:admins" content="100000195032462"100000195032462"/>
    <meta property="fb:app_id" content="1801701280113135"1801701280113135"/>

    I’m assuming you tried to list those twice?? or have quotes in that input in the plugin settings? (something I should filter in a future version). BUT… clean that up… also you only need one of those… either the adminID OR the appID. not both.

    Third Problem:
    You have another set of OpenGraph tags being output… if those are from your theme or another plugin i’m not sure but you need to figure that out and remove those.

    Do all that… THEN… run your site through Facebook’s Debugger and see how you’re doing. https://developers.facebook.com/tools/debug/echo/?q=http%3A%2F%2Fbaudorock.net%2F

    wlmweb

    (@wlmweb)

    Hello!
    Thanks for answering! I changed all the problems mentioned, but the code <meta name = ‘robots’ content = ‘noindex, follow’ /> is contained in the general-template.php file of the wp-includes folder that according to my hosting, can not be changed! Is there another way to change this setting?
    In advance, thank you very much!

    Plugin Author Chuck Reynolds

    (@ryno267)

    well if you want anything to index and see your site, including Google, Bing, Facebook, etc, you’re going to need to fix that noindex thing. If you don’t fix that, no plugin you ever use will help you. Talk to your theme developer, or web dev, or learn to edit that specific file with the wordpress editor or via sftp or something.

    wlmweb

    (@wlmweb)

    Hello
    Thanks for answering! What would be the ideal setting for meta tag robots?

    Plugin Author Chuck Reynolds

    (@ryno267)

    More likely than not you just want them to index the site so change it to this:
    <meta name='robots' content='index,follow' />

    (index,follow instead of noindex,follow)

    You can read more about robots metadata here: http://www.robotstxt.org/meta.html

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘facebook share button’ is closed to new replies.