WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Facebook Publicize not working properly

[Resolved] Facebook Publicize not working properly

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jeremy Herve

    @jeherve

    After some days, it started showing different thumbnails for different posts on facebook wall.

    When you share a post on Facebook, or when Jetpack Publicize publishes a post to your Facebook page, Facebook crawls the page and looks for Open Graph meta tags in the head to build a complete post preview (with an image, title, description, …).

    You can see what Facebook sees by entering one of your posts’ URLs in Facebook Debugger:
    https://developers.facebook.com/tools/debug

    Since you use the WordPress SEO plugin, all Open graph meta tags are managed by this plugin. You can go to SEO > Social in your dashboard to make sure the meta tags are activated.

    But now, it is posting completely wrong permalinks. My users get 404 error. I use .html in permalinks. But it posts URLs without .html.

    Could you go to the jetpack menu in your dashboard, and disconnect then reconnect to WordPress.com to make sure all your Jetpack settings are updated to use the proper permalink structure?

    If that doesn’t help, do not hesitate to let me know your permalink structure as it appears under Settings > Permalinks in your dashboard, and I will check whether your Jetpack settings are set to use the same Permalink structure.

    Thanks!

    Hello Jeremy!

    Thanks for the reply.

    Everything is working fine now! Thanks.

    HI, I keep getting the same 404 error when trying to cross-post to Facebook and Twitter using the Publicize plugin.
    I have reconnected Jetpack to WordPress, activated social meta data in the SEO plugin, everything. I just don’t know what to do.
    Could you please help me?
    http://northlondonboxing.co.uk/blog
    Many thanks,
    Matt

    Plugin Author Jeremy Herve

    @jeherve

    @mattkuppers As I mentioned here, Could you please start your own thread?

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Facebook Publicize not working properly’ is closed to new replies.