WordPress.org

Support

Support » Plugins and Hacks » Facebook » Facebook plugin causing page links to break / not be clickable

Facebook plugin causing page links to break / not be clickable

  • Hi ,

    I recently installed the facebook plugin and managed to get most of it working, but then I’ve realised that the page links within my page are not clickable on the front end of the site. ie when you load the page they show as a hyperlink, but when you mouseover them they’re not actually clickable. After about a minute or so they miraculously start working again.

    Deactivating the facebook plugin stops this problem from happening.

    Any ideas?

    http://wordpress.org/extend/plugins/facebook/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Niall Kennedy

    @niallkennedy

    What is the doctype of your site? (html5, xml, etc.)

    If you disable JavaScript in your browser does the problem go away? Do you have any JavaScript on your site acting on every link, such as an analytics plugin recording all outbound clicks?

    Hi,

    Thanks for the reply. Yes, disabling Javascript makes the problem go away, but it also seems to make the facebook link button etc go away.

    The doctype is:
    <meta http-equiv=”Content-Type” content=”text/html; charset=UTF-8″ />

    The web site in question is http://www.fyldescouts.org.uk

    There’s no other javascript acting on all links that I know of.

    Just tried disabling any other plugins which may be causing a conflict and the only way to get rid of the problem is to deactivate the facebook plugin. I’ve also timed the amount of time between the page loading and the links starting to work and it’s about 40-45 seconds.

    Again, this only affects links in the pages themselves, the sidebar and top menu work fine from the moment the page has loaded.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Facebook plugin causing page links to break / not be clickable’ is closed to new replies.
Skip to toolbar