WordPress.org

Support

Support » Plugins and Hacks » [Facebook Page Publish] Only posting defaul image

[Facebook Page Publish] Only posting defaul image

  • I’m using Facebook Page Publish to copy posts to my facebook wall. However the image that shows up on the wall, is always the default thumbnail. I’ve ticked the radio, saying use image from post, but it seems to ignore this. Any ideas what I may be doing wrong?

    My facebook wall:
    https://www.facebook.com/pages/Hi-Fi-Hunter/242185402481322?sk=wall
    Example WP post:
    http://www.hifihunter.com/2011/08/27/royd-minstrels-cheap/

    All posts in that category have the same problem. At first I was hoping it would use the large image near the bottom of the post. Next I tried adding a small thumbnail near the top, hoping it would pick this up.
    Both of these images are added to the post using my custom shortcode plugin and are referenced off ebay – could this be causing an issue?

Viewing 1 replies (of 1 total)
  • Investigating further I’ve found out:-

    Uploading and adding an image to the post normally, will publish correctly to facebook.
    Adding an image as a URL to offsite server to post, will publish correctly to facebook.
    Updating a post, adding/changing image on it and posting to facebook again, will not publish image correctly.

    So there seems to be a problem with:-
    Grabbing image I’ve inserted via my own custom shortcode.
    Grabbing image from an existing post that’s been published again.

    Any ideas?

Viewing 1 replies (of 1 total)
  • The topic ‘[Facebook Page Publish] Only posting defaul image’ is closed to new replies.
Skip to toolbar