Support » Plugin: Feed Them Social - Page, Post, Video and Photo Galleries » Facebook Options page is empty

  • Resolved dadkind

    (@dadkind)


    When trying to configure Facebook options, the options page is empty.

    This text displays, then nothing after that:

    Facebook Feed Options
    Change the language, color and more for your facebook feed using the options below.

    I’ve tried restarting apache with no success.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author slickremix

    (@slickremix)

    Thanks for contacting us. I would be glad to help out, can you please submit the report from the System Info page of our plugin. Click here if you are unsure how to do this. https://www.slickremix.com/docs/system-info-page

    Here is the info:

    ### Begin System Info ###

    SITE_URL: https://www.sierraforward.com
    Feed Them Social Version: 2.3.7

    — WordPress Configuration:

    WordPress Version: 4.9.4
    Multisite: No
    Permalink Structure: /%postname%/
    Active Theme: OnePress 2.0.2
    PHP Memory Limit: 256M
    WP_DEBUG: Disabled

    — Webserver Configuration:

    PHP Version: 7.0.25-0ubuntu0.16.04.1
    Web Server Info: Apache/2.4.18 (Ubuntu)

    — PHP Configuration:

    Safe Mode: No
    Upload Max Size: 2M
    Post Max Size: 8M
    Upload Max Filesize: 2M
    Time Limit: 30
    Max Input Vars: 1000
    Allow URL File Open: On ()
    Display Erros: N/A

    — PHP Extensions:

    FSOCKOPEN: Your server supports fsockopen.
    cURL: Your server supports cURL.

    — FTS Settings->Global Options:

    Cache time: 1 Day (Default)

    — Active Plugins:

    Display Posts Shortcode: 2.9.0
    Easy WP SMTP: 1.3.5
    Facebook Feed WD: 1.0.31
    Feed Them Social (Facebook, Instagram, Twitter, etc): 2.3.7
    Google Analytics for WordPress by MonsterInsights: 6.2.2
    Import Facebook Events: 1.5.0
    Ninja Forms: 3.2.14
    Recent Posts Widget Extended: 0.9.9.7
    Recent Posts Widget With Thumbnails: 5.2.1
    Redirection: 2.7.3
    The Events Calendar: 4.5.12.2
    Waiting: 0.4.5
    WordPress Importer: 0.6.3

    — Custom Token or Keys added to Options Pages
    — You must have a custom token to use the feeds

    Facebook App Token: No
    FB App ID for Like Button: No
    Twitter Consumer Key: No
    Twitter Secret: No
    Twitter Token: No
    Twitter Token Secret: No
    Pinterest Token: No
    Instagram: No
    YouTube: No

    — FaceBook & Twitter Date Format and Timezone

    Date Format: one-day-ago
    Timezone: No

    — Fix Twitter Time:

    Fix: No

    — Disable Magnific CSS:

    Fix: No

    — Fix Internal Server Error:

    ### End System Info ###

    Plugin Author slickremix

    (@slickremix)

    Please go to your wp-config file on the root of your wordpress install and turn on wp_debug mode. To do this change the false to true. Then look at the page in question again and reply with any errors that appear. This should lead us to the problem.

    Spencer

    Spencer,
    Here is the text of an uncaught error exception that was logged. How can I fix this?
    (It worked beautifully on my DEV box!)

    Fatal error: Uncaught Error: Call to undefined function feedthemsocial\simplexml_load_string() in /var/www/html/sierraforward/wp-content/plugins/feed-them-social/includes/feed-them-functions.php:2860 Stack trace: #0 /var/www/html/sierraforward/wp-content/plugins/feed-them-social/admin/feed-them-facebook-style-options-page.php(59): feedthemsocial\feed_them_social_functions->xml_json_parse(‘https://raw.git…’) #1 /var/www/html/sierraforward/wp-includes/class-wp-hook.php(286): feedthemsocial\FTS_facebook_options_page->feed_them_facebook_options_page(”) #2 /var/www/html/sierraforward/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array) #3 /var/www/html/sierraforward/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 /var/www/html/sierraforward/wp-admin/admin.php(224): do_action(‘feed-them_page_…’) #5 {main} thrown in /var/www/html/sierraforward/wp-content/plugins/feed-them-social/includes/feed-them-functions.php on line 2860

    Plugin Author slickremix

    (@slickremix)

    Thanks for the info, I suspected it had to do something with that. Double check with your host why your dev environment is different than the live environment. I’m guessing it has something to do with the xml_json_parse. Make sure that is available in your live environment too.

    Different providers.
    Dev is on aws
    Prod is hosted on 1and1.com

    Any other suggestions?

    Plugin Author slickremix

    (@slickremix)

    I would contact 1and1.com and tell them the dilemma and the error message that is coming up and that it worked on your dev environment. Sounds like they need to install a module to allow the XML json call to function properly. I wish I could offer more insight.

    Thank you so much for your help !!!

    Solved my problem.

    I needed to install package php-xml
    “sudo apt-get php-xml”

    I installed the package and now everything is working.

    The key is the line in the error that I posted previously:
    “Fatal error: Uncaught Error: Call to undefined function feedthemsocial\simplexml_load_string()”

    A little Googling led me to realize that I was missing a package on my server.

    Hopefully this will help you develop a better installation process so that you check to make sure that the package is installed.

    -tomas

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Facebook Options page is empty’ is closed to new replies.