Support » Plugin: Facebook for WooCommerce » Facebook Messenger not displaying

  • Hi

    Messenger for Facebook is enabled and I believe all Facebook Page settings are correct, however it’s not showing on the site, except for me (using Chrome). If I go incognito I don’t see it.

    If it’s any help, the developer console shows this error: Refused to frame 'https://www.facebook.com/' because an ancestor violates the following Content Security Policy directive: "frame-ancestors https://www.facebook.com"

    Thanks in advance for any help.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author SkyVerge

    (@skyverge)

    Hey @rsurfer,

    Thanks for writing in with your question! We’ve seen a few merchants struggle with the messenger being shown until they whitelist their domain name in the shop settings. To quickly check if this might resolve the issue for you, before we dig into further troubleshooting, would it be possible to add your store’s domain to the current whitelist?

    You can do this by logging into Facebook with your shop admin profile. Navigate to your shop page and click settings and then Advanced Messaging: https://cloud.skyver.ge/d5uvGr2X

    From here, scroll down to Whitelisted Domains and add your current store URL including the “https://” and click save.

    Does this make any difference to the messenger option being shown on your store when you refresh the page?

    Cheers!

    Simon.

    Hi Simon

    Thanks for the response. I had already ensured that the domain was whitelisted.

    Paul

    Hi,

    I have the same problem at the moment. I have also checked if the domain was whitelisted.

    Plugin Author SkyVerge

    (@skyverge)

    Hey @rsurfer,

    Thanks for checking that. I just checked your site URL (I should have done that first time around, I’m sorry!) and noticed that the chat bubble is showing for me also in a normal Chrome window, though as you say, an incognito window hits the error you’ve mentioned.

    The only difference I can see here is that Facebook is responding to the chat request with different content-security-policy: frame-ancestors in the response headers. The normal browser allows the frame-ancestor to be your site URL, whereas the incognito window only allows facebook.com.

    @feelingpeachynl Are you seeing the same error in your testing, or is the standard browser window also not working?

    Cheers!

    Simon.

    @skyverge That’s interesting. I also see it in Safari, but not in private browsing modes, or Firefox, or in any browser on a mobile.

    Plugin Author SkyVerge

    (@skyverge)

    Hi @rsurfer,

    I’ve tested again this morning on my local site and my incognito windows are also working as expected. I tried Firefox, as you mentioned this as well, and the only way I was able to prevent that from working is by using the Facebook Container add-on. As soon as I allowed my test site to load the scripts through the Container add-on, the chat bubble appeared as expected again.

    I did a bit more digging and came across this Stack Overflow question that deals with the same issue. I’ve had a look at the requests made between my test site and your live site, and can’t see any difference. Yet the frame-ancestors using an incognito window on your site is returning facebook.com rather than your own site URL.

    Are there any differences for guest/incognito users in terms of your webserver configuration? If you login to a customer profile while using the incognito window, does this have any effect either?

    Cheers!

    Simon.

    Hi @skyverge

    Thanks for digging further.

    I’m not sure I quite follow ref customer profiles.

    Do you see chat when viewing the site in any mobile browsers?

    I’m running another Woo site on the same server as this site, using the same plugin to enable Messenger and with that site it’s showing everywhere (even incognito), so I assume that rules out server config issues?

    Appreciate your help Simon.

    Paul

    Plugin Author SkyVerge

    (@skyverge)

    Hey @rsurfer,

    On my local test site, I am seeing it for mobile browsers, incognito, and different desktop browsers. I can’t replicate the issue at all there!

    The only place I can see the issue is on your site through an incognito window. I tried your site through a mobile browser and can see it there also. However, when I switch to a browser incognito tab, it fails to load again.

    At this point, I’m afraid I’m running out of suggestions! There doesn’t appear to be an issue with the plugin itself, otherwise, I would expect to see more reports of this failing and hopefully be able to replicate it locally too. You’ve mentioned it also works fully on your other site which is on the same server, so that seems to rule out a server/web server issue as well.

    I can’t see anything different between the requests made using your site when browsing an incognito vs normal window, other than the different response to the frame-ancestors CSP header that Facebook returns. Presumably, this is the same on the mobile incognito tab too.

    I would suggest reaching out to Facebook support directly to see if they have a better idea as to why this might be happening. Whether other users or developers have seen this before and if there is some nuance to the request that we’re missing. I’m sorry that I couldn’t find a complete solution for you this time around!

    Will you let me know if they are able to offer any suggestions for fixing this?

    Cheers,

    Simon.

    @skyverge It’s not working in my normal browser either. The website URL is https://www.feelingpeachy.nl.

    @skyverge Thanks Simon, I appreciate the time and effort you’ve put into trying to find a solution.

    For mobile searches, were you using iOS or Android? I don’t know if it makes a difference. I’ve tried Safari and Chrome on iOS (non-private browsing) and it doesn’t appear.

    I’ll reach out to Facebook and let you know if I get any useful suggestions.

    Thank you once again.

    Paul

    Plugin Author SkyVerge

    (@skyverge)

    Hey @rsurfer,

    Awesome, thanks for letting me know. Sorry again that we didn’t get to the bottom of it, it’s proving to be a tricky one! I was using Android in my tests, with the standard Chrome browser if that helps.

    @feelingpeachynl thanks for passing on your URL. I see that the chat scripts are not initialized unless I accept all of the marketing options in the cookie notice. Once I do this, the chat shows as expected: https://cloud.skyver.ge/RBuqKwPB

    Does this work for you also?

    Cheers,

    Simon.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.