Support » Plugin: WordPress Social Login » facebook login not working

Viewing 5 replies - 1 through 5 (of 5 total)
  • I am also facing the same issue on my client website. Can anyone help me to figure it out.
    Valid OAuth Redirect URIs = https://notebuyergo.com/wp-content/plugins/wordpress-social-login/hybridauth/?hauth.done=Facebook

    AND it showing following error while attempting to login:
    ERROR:
    URL Blocked: This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings. Make sure Client and Web OAuth Login are on and add all your app domains as Valid OAuth Redirect URIs.

    If you go to https://developers.facebook.com and edit your app, you then need to go to the left sidebar and under “Products” you will find “Facebook Login”. Expand it and click on “Settings”. Then in the “Valid OAuth Redirect URIs” field enter the following: http[s]://[yourwebsitedomain]/wp-content/plugins/wordpress-social-login/hybridauth/?hauth_done=Facebook and save the setting.

    Be sure to replace http[s] with either http or https, depending on your setup and the [yourwebsitedomain] with your actual domain.

    Then, in the “Redirect URI to Check” field at the very bottom of the page, put that same URL above in this message thread in that field and test it. It should come back as working.

    Then, go to your website and test it.

    This should work up until August 1, 2018 as at that point you need to submit an app review or it won’t work until Facebook reviews and approves it.

    I hope this helps.

    @wrhull i did what you suggest, but problem still persist 🙁
    https://www.sobrecroacia.com/wp-content/plugins/wordpress-social-login/hybridauth/?hauth.start=Facebook&hauth.time=1529507365

    Ahh..ok..there was a problem with plugin “wp nativ php session”…
    After uninstall plugin all ok!
    Thank you
    [20-Jun-2018 09:21:51 UTC] PHP Warning: ini_set(): A session is active. You cannot change the session module’s ini settings at this time in /home/aodaguar/public_html/sobrecroacia.com/wp-content/plugins/wp-native-php-sessions/pantheon-sessions.php on line 124

    • This reply was modified 3 years, 7 months ago by principiante.
    • This reply was modified 3 years, 7 months ago by principiante.

    Hmmm… Did the “Redirect URI to Check” work for you before you tried it on your website? This would be from the Facebook app on developers.facebook.com. You need to make sure the Redirect URI to Check shows that it is a good address.

    Thanks,
    Will

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘facebook login not working’ is closed to new replies.