Support » Plugin: WordPress Social Share, Social Login and Social Comments Plugin - Super Socializer » Facebook Log in Valid OAuth Redirect URIs + Site Url

  • VitaSerk

    (@serkankurnaz)


    Hello,

    first of all, thank you very much for that great plug-in! I really love it 🙂

    But i got an error setting up the plug-in with my facebook developer log in…I used the step by step tutorial:
    http://support.heateor.com/how-to-get-facebook-app-id/
    It is a bit confusing what to add to
    1.) App Domains
    2.) Site Url
    3.) Valid OAuth Redirect URIs

    So my website looks like following:
    https://MYWEBSITEID.de

    Could you please tell me, what to add exactly.
    I get the error:
    Add https://MYWEBSITEID.de/?SuperSocializerAuth=Facebook in “Valid OAuth redirect URIs” option in your Facebook app settings for Facebook login to work. For more details, check step 9 here.

    Thanks a lot!

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Heateor Support

    (@heateor)

    Hi there,

    Thanks for the appreciation 🙂

    Make sure you have saved exactly the following domains in the App Domains option in Facebook app settings (step 7 http://support.heateor.com/how-to-get-facebook-app-id/):
    vitasation.de
    www(DOT)vitasation(DOT)de

    ..and exactly the following two urls in the Valid Oauth Redirect URIs option (step 12 http://support.heateor.com/how-to-get-facebook-app-id/):
    https://vitasation.de
    https://vitasation.de/?SuperSocializerAuth=Facebook

    In Site URL option, you have to save url of homepage of your website https://vitasation.de

    VitaSerk

    (@serkankurnaz)

    Hello,

    ty! it worked now 🙂

    PS: i got following error for google log in:
    Fatal error: Cannot declare class Google_Service, because the name is already in use in /wp-content/plugins/super-socializer/library/Google/Service.php on line 18

    why is that? Becuase I named it the same name as i called facebook log in?

    thanks!

    VitaSerk

    (@serkankurnaz)

    PPS:

    On my staging site, same wordpress+astra 2.0 theme, and nearly all same settings it works. No Error code there 🙁

    So i guess there is a mistake with a plug in like google site kit? or PixelYourSite?

    Thanks!

    VitaSerk

    (@serkankurnaz)

    any help please?

    Plugin Contributor Heateor Support

    (@heateor)

    PS: i got following error for google log in:
    Fatal error: Cannot declare class Google_Service, because the name is already in use in /wp-content/plugins/super-socializer/library/Google/Service.php on line 18

    Seems some other plugin is also using the class with the same name without checking first if it’s being used in some other plugin/theme. You can confirm the same by keeping only this plugin active.

    VitaSerk

    (@serkankurnaz)

    How can I find out, which plug ins, uses what exactly of google?
    I am a bit confused 🙁
    As said I just use Super Social Log In.

    I use following Goole Plug Ins:
    Google Analytics Opt-Out (DSGVO / GDPR)
    Google Captcha (reCAPTCHA) by BestWebSoft
    PixelYourSite
    Site Kit by Google

    Would be nice to find a solution 🙂

    Plugin Contributor Heateor Support

    (@heateor)

    You can start by keeping only this plugin active and then checking by activating other plugins one-by-one to identify the one which is causing the problem.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.