WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Facebook Like button not working

[Resolved] Facebook Like button not working

  • Hello,

    It seems the Facebook Like button isn’t working. (other buttons, Twitter etc, do work).
    When you click the like-button the number 1 (testing with article whiwh has no likes), but immediatly disappears again. Not has been liked on facebook. When you refresh the page, you see 0 again, and nothing has been added to the facebook wall.

    Does anyone else have this problem, could it be a bug in the plugin?

Viewing 15 replies - 1 through 15 (of 21 total)
  • I am having the exact same problem. I have tried 3-4 different plugins and 2 different themes (including Twenty Ten)… When I click the Like button it first apperars to register the like but when you refresh the page it’s like nothing happened.

    Seems like it’s happening everywhere… I’ve just tried it on another site (problogger).

    Helo,

    Have you already find the solution? I’ve the same problem.

    David

    Helo,

    A workaround described here: http://forum.developers.facebook.net/viewtopic.php?pid=357482 at #7.

    D

    I believe it was indeed a problem at Facebook’s end. Issue is fixed now.

    I got the same problem, tried the same problem but it didn’t help. It turns out to be a bug in the plugin.

    Before passing the URL of the post to the like button that URL needs to be encoded.

    Here is the fix. Edit the plugin and find the following code:
    <iframe src="http://www.facebook.com/plugins/like.php?href='.$link.'

    Replace it with:
    <iframe src="http://www.facebook.com/plugins/like.php?href='.urlencode($link)

    As you can see it works fine now, see example here:
    http://www.dataminelab.com/blog/behavioural-targeting-online/

    Here is the fix. Edit the plugin and find the following code:
    <iframe src=”http://www.facebook.com/plugins/like.php?href=’.$link.’

    Replace it with:
    <iframe src=”http://www.facebook.com/plugins/like.php?href=’.urlencode($link)

    Still having this issue in latest version of this plugin.

    I tried the above but it doesnt work, are you sure the code detailed is exactly correct?

    Hope someone can help,

    Thanks

    DG

    It fixed the issue in my case. Once again the code:

    <iframe src="http://www.facebook.com/plugins/like.php?href='.$link.'

    Replace it with:
    <iframe src="http://www.facebook.com/plugins/like.php?href='.urlencode($link).'

    So basically the only thing you need to do here is replace the “$link” with “urlencode($link)”.

    Hope it helps.

    Thanks again Radek I’ve tried your suggestion and edited the code but the “like” still isnt registering.

    The “1” shows then quickly disappears.

    Can you provide a link to your page?

    today same problem on my site… tried all plugins but nothing hppnd..

    having the same problem on http://grolschblockparty.se/

    you click “like” but nothing is logged on facebook

    Silviu

    @scutariusilviu

    Try Shareaholic! Is not the like buton, but works for fb. It’s a nice tab, that can be customized.

    Hi all,
    release 1.6.2 of the Really Simple Facebook Twitter Share Buttons plugin is out, fixing the Facebook Like button recent issues.

    Many of you noticed that the button wasn’t always working, due to an update on the Facebook side, which has limited the accepted url format.

    As Radek Maciaszek (thanks!) correctly figured out, the issue is solved encoding the url. Please update your plugin… and forgive our delay, we’re on vacation!

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] Facebook Like button not working’ is closed to new replies.