WordPress.org

Support

Support » Plugins and Hacks » Facebook Integration

Facebook Integration

  • First off, thanks for the application. It looks great and I am excited to use it once I get it going.

    I am attempting to set up the Facebook Integration and am repeatedly receiving the API Error Code 191
    API Error Description: The specified URL is not owned by the application
    Error Message: Invalid redirect_uri: Given URL is not allowed by the Application configuration.

    What am I doing incorrect here?
    I’m trying to fully understand all of the jargon but am lacking here. Please help!

    http://wordpress.org/extend/plugins/wp-bulletin-board/

Viewing 15 replies - 1 through 15 (of 23 total)
  • Now when I click “Login Using Facebook” I receive this alert:

    You must register for an account using WordPress or Facebook before logging in

    I’m so lost.

    Plugin Author codebycarter

    @codebycarter

    Hey,

    You’ll just need to make sure that the link you access your forum from is entered as the redirect url in your facebook settings in settings -> wpbb settings and that it is also the same over at facebook e.g. “http://mywpsite.com/forums” or “http://mywpsite.com/?page=12002”

    Yes you’ll also need to register using facebook first, which basically just registers a WordPress account for you. Makes it easy for administrators to keep track of facebook registrations in my opinion, rather than allowing anyone with a facebook account to login and use the forum. Haven’t looked into it too much though, so it could all change someday, but that’s what you have to do atm.

    Hi, I am having trouble with the Facebook integration also. I have been trolling through the help forums to see if I could find the answer but haven’t so far.

    I followed the useful directions you had posted on the F.A.Q.’s which explained step by steps how to set up the Facebook App. Where FB asks for ‘Site URL’, I entered the following address where the forums are located: “http://www.birdsleuth.org/ambassadorhome/forums/”

    When I was done, I went to test out the “Register Using FB” option only to get this message: “Unable to load the registration form for this ID. You may have previously blocked this app on Facebook. Go to your Facebook privacy settings to unblock this app. (Error: Invalid ‘client_id’.)”
    Otherwise I was getting the following message: “The redirect_uri URL must be absolute”

    What does this mean and how can I fix the problem?
    Thanks in advance for your help.

    After further investigation, the problem, we have realized, is that in the WPBB settings, the “My App ID / API Key” form will not accept more than 10 digits. Our FB App ID has over that number–15 digits to be exact.

    Help?
    Thanks.

    I am facing the same issue with lleana “My App ID / API Key” form will not accept more than 10 digits“. please help.

    Thank you so much

    This is my app id from facebook developer = 602190456459187, but after i click save Facebook settings WPBB automatically change back to this number 2147483647.

    Dear vessel65,
    I am having the same problem right now. Any way to resolve this?

    Vessel65 and Bridgetoindia,

    This has not yet been resolved for me. Vessel, it seems that the app ID was automatically changing for us as well.

    Still looking to get some support on this…

    Hi Ileana,
    Turn off ‘sandbox mode’ in the Facebook app and fill the App ID again.

    Hi, “Sandbox mode” was already disabled and I believe there is no way to change the App ID. You can only reset the “App Secret”

    Has anyone found a solution to this? I really like the forums module, but FB integration is KEY.

    The Author Jack Foreigner

    @the-author-jack-foreigner

    Bump: I don’t even get any error messages; there’s just no Facebook anything on my WPBB forums page!!

    Has anyone figured out this issue?

    “This is my app id from facebook developer = 602190456459187, but after i click save Facebook settings WPBB automatically change back to this number 2147483647.”

    This is exactly what’s going wrong with mine…..

    I just emailed WPBB and waiting on reply.

    Thanks in advance

    No luck yet… still hoping for some sort of response but also willing to use another forum platform if I come across one that looks good. If anyone has any suggestions, or has found an alternative, please let me know.

    Admins? Does this mean we should use another plugin all together?

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Facebook Integration’ is closed to new replies.