Yoast SEO
Facebook Insights and Admins not working (10 posts)

  1. Energias
    Posted 3 years ago #

    Facebook Insights and Admins

    Add Facebook Admin

    Use a Facebook App as Admin

    Nothing of this works!


  2. Hasdai
    Posted 3 years ago #

    I have the same problem. I tried to "Add Facebook Admin" but this took me to a 404 page on my own site. I logged into Facebook as my Facebook page, and when I tried to "Add Facebook Admin" again through the plug-in, this got me as far as a connection to Facebook, where I was prompted to switch over to using FB as my profile. I made this switch, which got me as far as having the WordPress SEO Facebook app installed, and even adding my pages to manage, then got me to a page that told me what my ID's were for my profile and pages. But this seems to have had no effect on the page data and when I tried to click on "Add Facebook Admin" again back in my CMS, I again got a 404 page on my own site.

  3. Rajesh Namase
    Posted 3 years ago #

    Yeah 404 error, unable to add admin or FB app there, Joost please try to solve this problem.

  4. japanworm
    Posted 3 years ago #

    Same issue here! :(

  5. Energias
    Posted 3 years ago #

    Still the same error

  6. Jatin Gupta
    Posted 3 years ago #

    I am too having same problem

  7. rafikipress
    Posted 3 years ago #

    WordPress version: 3.5.1
    WordPress SEO version: 1.4.2

    I did this:

    Installed WordPress SEO, tested Facebook Admin, not working.
    Disables all plugins, not working.
    Activated 2012 Theme, not working.
    Disabled and uninstalled WordPress SEO.

    I expected the plugin to do this:

    Add Facebook Application as Admin.

    Instead it did this:

    Added Facebook Application as Admin.
    Nothing Happened.

  8. Myk Klemme
    Posted 3 years ago #

    Had the same problems, now it is working! Here's what I did:

    1. Choose the "Use Facebook admin" button.
    2. The page returns a 404! Oh noes :(
    3. Change the URL (remove the bolded part of your URL):
    from this: http://url.com/wp-admin/admin.php?page=wpseo_social&key=SECRETNUMBERSOHMY&userid=0000&userrealname=My%20Name&link=http://www.facebook.com/w00tw00t#_=_
    to this: http://url.com/wp-admin/admin.php?page=wpseo_social&key=SECRETNUMBERSOHMY&userid=0000&userrealname=My%20Name
    4. Party time! Now add the URL to the Facebook insight dashboard, the meta tag is now live.

    Throw a response if it still isn't working. :)

  9. mrkingid
    Posted 3 years ago #

    i can add my facebook account now but I cannot get insights at all.

    i try to add http://www.mysite.com/ on the insights pagte and it rejects it and gives me...

    No admin data found at root webpage http://mysite.com/. Insights requires admin data at this root webpage for the specified URL mysite.com

    any ideas?

  10. Ben May
    Posted 2 years ago #

    I've got the same error too.

    the plugin should be outputting this in the header

    <meta property="fb:admins" content="1234567" />

    1234567 being your Facebook User ID.

    You can just add the HTML yourself, and find your fb user ID here: findmyfacebookid.com.

    Used to work - however new sites it doesn't appear to work

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic