WordPress.org

Forums

[resolved] Facebook feeding showing ONLY "g" gravatar image (21 posts)

  1. avcnews
    Member
    Posted 4 years ago #

    guys help me here, pelase. I have a woo premiumnews template and the god damn Share and Follow plugin (wich i THINK may be causing this issue, even thuo the Auto Share Post image funton is off).

    When I click on "Share on facebook link" at anywhere in my page it stopped showing the post's image and it only displays that blue big G from gravatar. I dont know where else to get it back working normally.

    I need to release my website wich is my job, and i need urgen help. Thanks in advance.

  2. andykillen
    Member
    Posted 4 years ago #

    bit of a hint first. don't go slagging off other peoples work if you want support in future. I won't give you the time of day if you write like that again.

    Your obviously having issues with the Share Image url. you have the choice of how you want Facebook to get your share image.

    1) Don't have the part setup at all as then Facebook will get the users the option to show whatever they like from the images from the post. So TURN IT OFF.

    2) If the Share image setup is TURNED ON.... Setup Gravatar id's for your author email addresses so that it shows that an not the G of gravatar. This will work if you set the system to show the GRAVATAR image from the author email.

    3) If the Share image setup is TURNED ON.... Use the wordpres Media library rather than hand editing and inserting the images into posts. The plugin relies on the images to be inserted into posts using this method. If you don't use it in this fashion or don't have an image in the post it will default to the Gravatar image of the author of the post (or your default gravatar image should you have set that up)

    4) If the Share image setup is TURNED ON.... Setup a site logo and in the Who, What, Where section and then that will be the share image

    5) If the Share image setup is TURNED ON.... use the custom field of "image_src" and make the data of that field to be the FULL url of what you want to be showing in facebook as the share image.

    So basically either you've not setup gravatar images, your hand editing and inserting HTML, or your not using the image_src custom field.

    DO BE WARNED. FACEBOOK CACHES THE IMAGES FOR 24HRS OR SO. YOU WILL NOT ALWAYS SEE YOUR CHANGES.

    If you want to check the specific url that is setup by the share and follow plugin then you will need to look in the head section of the page and search for image_src. If that is not in the HEAD section then there is nothing happening from the Share and Follow plugin.

    Any further help will have to come from WOO! themes as they hold the support effort on premium product.

    and remember, keep your language nice or I will be forced to be 10x worse in replies. And lets face it as this is your 'job' and you need urgent help, you should consider what you write more carefully.

    Andy Killen

  3. avcnews
    Member
    Posted 4 years ago #

    ... reading

  4. andykillen
    Member
    Posted 4 years ago #

    oh a Journalist. you really should consider what you write more carefully.

  5. avcnews
    Member
    Posted 4 years ago #

    Andy, i meant no disrespect I am just under a deadline here and I already tried to get in touch wth Share and Follow staff before with no sucess. Anyways, sorry for the words u considered offensive to ur work, wich is great so far.

    Anyways, thing is: image share option is off, I allways want for facebook to use my post's image.

    1)So when u say "FACEBOOK CACHES THE IMAGES FOR 24HRS OR SO. YOU WILL NOT ALWAYS SEE YOUR CHANGES." it means taht any images taht i post on my posts will take 24hs to be avable to people to share that on FB?

    2) I unistalled share and follow and still got the Gravatar G, is that a matter of facebook cache? (i reinstalled again with the share image off cuz ya ur plugin/work are great)

    Thanks for ur attention and sorry again

  6. avcnews
    Member
    Posted 4 years ago #

    I never turned the Setup share image ON. So is this feature, when installed, by default ON?

  7. andykillen
    Member
    Posted 4 years ago #

    yes it is by default on.

  8. avcnews
    Member
    Posted 4 years ago #

    and it came recently with the new update? Its OFF for more than 13 hours now... is tehre anything ELSE taht could be interfeering on the FAcebook feeding? Will i be getting my posted images back on my facebook feeding? UNtill there i cant say this topic is resolved.

  9. andykillen
    Member
    Posted 4 years ago #

    In reply to your other questions.

    Facebook will always cache all images that it touches, be that photo's in a library or share images from posts. In this occasion facebook will cache the 1st image that gets associated with the share URL will be cached by facebook for 24hrs. So that when other people come for that same share, the image is already in their cache and faster to load.

    Yes I expect that it is the G that is in the facebook Cache. However this does mean that there was some configuration done of the plugin as by default the image_src is blank forcing facebook to read all the images on the page.

    Sometimes (facebook is not always consistent) it is possible that when different [facebook]users share the URL it will update the image cache instantly with the new URL of the new image_src. So if you want to test it I would recommend setting up a 2nd facebook account as a dummy user and test it with that.

  10. andykillen
    Member
    Posted 4 years ago #

    I have seen it before where facebook fails to add the share image with or without an image_src setup.

    There is nothing that anybody can do to fix this, you can try to complain at facebook, but how?

    In general when this happens to a site (yes it seems to be on a site by site basis) the only thing to do is wait. It usually rights it's self within 3 days.

  11. avcnews
    Member
    Posted 4 years ago #

    I am gonna wait with all the patience avaible... I jsut hope its not anything permanent. I must handle the website impecable for the other contribuitors that will wirte there within 5 days.

    I made a list of the plugins isntalled to see if u remember of anything tat may be causing this malfunction:

    AddToAny: Share/Bookmark/Email Button (inserted on Featured.php)
    Akismet
    Contact Form 7
    Footer Sitemap
    Google Analytics for WordPress
    Google XML Sitemaps
    Posts Protect Quiet
    Regenerate Thumbnails
    Secure WordPress
    Share and Follow (hehe)
    Sharebar
    Simple Facebook Like
    Smart Youtube
    Snazzy Archives
    WordPress Admin Bar
    WP Post Thumbnail

    I am taking ANY kindda sugegstions... tahnks agian for ur time.

  12. andykillen
    Member
    Posted 4 years ago #

    Without being able to view your site there is little more I can do. I expect this is all based around facebook and not your theme or plugins.

  13. avcnews
    Member
    Posted 4 years ago #

    Is there any possibility for me to add u on msn so i can voluntarialy borrow my admin password and u can perform an ultra fast check up? or send u via private message here.. if u got this little time to spare to this individual taht started things on the wrong foot with ya :/

  14. andykillen
    Member
    Posted 4 years ago #

    You can find us on skype

    skypename: shareandfollow

    we don't do msn. I don't need admin access only a link to the site at the moment. that way I can see what is going on with the out put code.

  15. avcnews
    Member
    Posted 4 years ago #

    Here u go, andy

    http://avcnews.org/

    catch u on skype. thanks again

  16. andykillen
    Member
    Posted 4 years ago #

    I've checked your site and it is an issue based with facebook and maybe their caching. There is no image_src on any of the pages so facebook should offer the users a selection of images from the post.

    I think you are stuck with waiting on facebook to resolve this

  17. avcnews
    Member
    Posted 4 years ago #

    Had myself linked the website with a API i have in FB, could this be causing all the conflict? U are way more experinced than me on this matters. I am really new to site building.

    Considering taht i started having this problem yesterday, 16 hours ago, when should i start to realyl worry if the images dont show up on facebook feed? cuz I will ahve to report taht to my journalist collegues that i may have screw up the most important sharing tool........ omg...

  18. AVGoncalves
    Member
    Posted 4 years ago #

    how you resolved the problem? i'm i n the same situation.. please

    thank you

  19. andykillen
    Member
    Posted 4 years ago #

    There was no problem here, it was User error. The expected different functionality and moaned about the standard operation.

    I have no control over facebook caching which this user did not understand at all. Please read about caching also so that you know what it is http://en.wikipedia.org/wiki/Cache

    facebook caches for 24 hrs.

  20. masterbassie
    Member
    Posted 4 years ago #

    not ideal but a workaround is to slightly change the title (and subsequently the slug) of the post. This will cause facebook to cache a new image preferably (i.e. hopefully) the one you want.

  21. iqftp
    Member
    Posted 4 years ago #

    Also, if you delete and recreate the post after fixing the settings, it will work because it changes the URL. This is only a good idea if no one has linked to your post yet since any old links will be broken.

Topic Closed

This topic has been closed to new replies.

About this Topic