• Resolved jriangle

    (@jriangle)


    I have used this on countless websites. It is working find on all of them, but no matter what I do is just will not work on my site LuzRosa.com.

    I’m not doing anything different and have spent 3 hours trying various possibilities. It’s not the other plugins. It’s not the extra CSS I’ve added. It’s something about site because no other widget will work either (other than Jetpack…whick looks like crap with no real settings).

    What setting could be interfering with the short code?!

    I’m even using the same plugins theme etc as many other sites I’ve built.

    Example – Realtors.video

Viewing 15 replies - 1 through 15 (of 16 total)
  • Thanks for contacting us. I would be glad to help out, can you please include these 3 things?

    1. The shortcode you are trying to use.
    2. An example link to the problem in question.
    3. The report from the System Info page of our plugin. Click here if you are unsure how to do this. https://www.slickremix.com/docs/system-info-page/

    Damon

    [fts_facebook type=page id=664174253778002 posts=6 posts_displayed=page_only]

    I have deleted it because it does something to SiteOrigin Page Builder on that page. I will make a new page with the problem duplicated. The top menu is not full width and even some of the WordPress buttons are missing. It has to be some new defaulted setting somewhere because your widget always works and works better than the others. It is currently working on 10+ of my sites. Link Below.

    http://luzrosa.com/test-page-for-feed-them-social/

    ### Begin System Info ###

    SITE_URL: http://luzrosa.com
    Feed Them Social Version: 2.2.5

    — WordPress Configuration:

    WordPress Version: 4.8
    Multisite: No
    Permalink Structure: /%postname%/
    Active Theme: Perth Pro 1.23
    PHP Memory Limit: 512M
    WP_DEBUG: Disabled

    — Webserver Configuration:

    PHP Version: 5.6.30
    Web Server Info: Apache/2.4.25

    — PHP Configuration:

    Safe Mode: No
    Upload Max Size: 1G
    Post Max Size: 128M
    Upload Max Filesize: 1G
    Time Limit: 30
    Max Input Vars: 1000
    Allow URL File Open: On ()
    Display Erros: N/A

    — PHP Extensions:

    FSOCKOPEN: Your server supports fsockopen.
    cURL: Your server supports cURL.

    — Active Plugins:

    Feed Them Social (Facebook, Instagram, Twitter, etc): 2.2.5
    Jetpack by WordPress.com: 5.0
    Page Builder by SiteOrigin: 2.5.7
    Simple Share Buttons Adder: 6.3.6
    SiteOrigin Widgets Bundle: 1.9.2
    Toolset Types: 2.2.13
    Wordfence Security: 6.3.12

    — Custom Token or Keys added to Options Pages
    — You must have a custom token to use the feeds

    Facebook App Token: Yes
    FB App ID for Like Button: No
    Twitter Consumer Key: No
    Twitter Secret: No
    Twitter Token: No
    Twitter Token Secret: No
    Pinterest Token: No
    Instagram: No
    YouTube: No

    — Offset Post Limit:

    Offset Facebook Post Limit: None
    Hide Notice on Front End: Yes

    — FaceBook & Twitter Date Format and Timezone

    Date Format: one-day-ago
    Timezone: America/Chicago

    — Fix Twitter Time:

    Fix: No

    — Disable Magnific CSS:

    Fix: No

    — Fix Internal Server Error:

    ### End System Info ###

    The only way to get the shortcode to output proper is to add it to a text type page builder option. Make sure not to use the design tab but the text tab.

    Thank you… but I did that long before reaching out for help. I just tried it again. All I ever get now is “#190 – Error validating application. Invalid application ID. Here are some possible solutions to fix the error.”

    Seems like something else is causing the issue. You need to deactivate all plugin and then test to see if the issue goes away. If it does work then turn each plugin back on on by one until you see the error come back.

    Thats not it either. It also seems to interfere with how the page is drawn. It is still working on other sites done in the past but no matter what I doesn’t seem to work currently with SiteOrigins Page Builder.

    Hi jriangle,

    Does the plugin work for you if you enable the Content Cache? Please navigate to WP Admin > Settings > Page Builder and open the Content tab. Tick Content Cache and then save. Does it work now?

    That was it. I knew it had to be something simple but just couldn’t see it. Thank you very much Alexgso. I owe you one. J. Jriangle.com

    Plugin Author slickremix

    (@slickremix)

    @alexgso You are the man! Thanks for helping out here because I was at a loss for this issue. I even installed the plugin with default settings and didn’t encounter this issue and even though we have tested against this plugin many times through the years I’ve not seen this come up.

    Page builder plugins have contributed to more support topics created than just about anything else throughout the last few years for us sadly. I love page builder plugins but for some reason none of them consistently hold a standard for handling shortcodes and it is a bit frustrating at times to say the least.

    @jriangle thanks so much for hanging in there and having the patience to work through this issue. I know at times as a developer we don’t have complete control over the page builders we are able to use based on the themes clients want. All we can hope for is that the page builder developers create clearer instructions on workarounds for shortcode issues. I know a lot of them have them but they are usually not so transparent.

    Spencer

    Hi slickremix,

    I’m sorry to hear that mate. If it helps, this is what the content cache does:

    Generates and stores the output of the page on save (or load – whichever is first). Then it displays this content through the_content at priority 1. This will typically resolve issues where plugins filter the_content before default priority – we… well, we basically destroy anything run before our page builder filter as the content previously present is at best basic and at worse not even there.

    Regarding shortcodes. If the user is using the SiteOrigin Editor widget, get them to disable Automatically add Paragraphs (which runs wpautop really late). I currently recommend against the WordPress text widget at this time due to the recent 4.8 changes (which has caused quite a number of formatting issues).

    If you have any specific issues that you can’t work out, feel free to reach out.

    Plugin Author slickremix

    (@slickremix)

    @alexgso Awesome thanks again for the insight it was very helpful.

    Well… This is insane. On the second site no of the above helped. It is the second and main site4 of the person from above e problem. We found what it was and it worked immediately but doing literally everything and the new info and still can’t get second site to work. More than frustrating. I spent all day judging 2 of my sites just because I build a large portion of them with a Jetpack widget that they just dropped a few weeks ago with no warning. I have many, many more to rebuild now before I can update to latest WordPress now.

    Plugin Author slickremix

    (@slickremix)

    @jriangle I can feel your frustration in in the paragraph you wrote :/ Just to clarify is there anything else we can do to help or this something with another plugin and wordpress?

    Fixed… again. That page said it required a KEY. I got one. Something was ultimately wrong with it. I deleted and is said I’m not use ” a general key” or something to that effect. Works perfectly as it always did now. Damn updates. Thanks again for help and great plugin Slick Remix.

    Now the videos are not showing, just the text. There were a lot of updates this last week.

    http://RealtorsWeb.site

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Facebook Feed will not work’ is closed to new replies.