• Resolved titch71

    (@titch71)



    Hi,

    We updated to the latest version of the plug-in just after updating to the latest version of wordpress and its stopped working. I thought it was working before but cant be 100% sure.

    The error message is below

    Warning: Creating default object from empty value in /homepages/number/number/htdocs/clickandbuilds/website/wp-content/plugins/feed-them-social/feeds/facebook/facebook-feed.php on line 408

    Warning: Invalid argument supplied for foreach() in /homepages/number/number/htdocs/clickandbuilds/website/wp-content/plugins/feed-them-social/feeds/facebook/facebook-feed.php on line 648

    Warning: Invalid argument supplied for foreach() in /homepages/number/number/htdocs/clickandbuilds/website/wp-content/plugins/feed-them-social/feeds/facebook/facebook-feed.php on line 658

    For security purposes i have replaced /number/number and /website info

    Cheers

Viewing 11 replies - 1 through 11 (of 11 total)
  • Tried resetting everything and then it worked for about 30 seconds then gave the same error again. Sad times

    Plugin Author slickremix

    (@slickremix)

    Thanks for contacting us. I would be glad to help out, can you please include these 3 things?

    1. The shortcode you are trying to use.
    2. An example link to the problem in question.
    3. The report from the System Info page of our plugin. Click here if you are unsure how to do this. https://www.slickremix.com/docs/system-info-page/

    Please find requested info below – cheers for the update

    [fts_facebook type=page id=368110006581788 posts=5 posts_displayed=page_and_others]

    http://dgtriclub.org/

    ### Begin System Info ###

    SITE_URL: http://dgtriclub.org
    Feed Them Social Version: 2.4.0

    — WordPress Configuration:

    WordPress Version: 4.9.6
    Multisite: No
    Permalink Structure: /%postname%
    Active Theme: D&G Tri Club Child Theme Test 1.0
    PHP Memory Limit: 268435456
    WP_DEBUG: Disabled

    — Webserver Configuration:

    PHP Version: 7.0.29
    Web Server Info: Apache

    — PHP Configuration:

    Safe Mode: No
    Upload Max Size: 67108864
    Post Max Size: 67108864
    Upload Max Filesize: 67108864
    Time Limit: 30
    Max Input Vars: 1000
    Allow URL File Open: On (1)
    Display Erros: On (1)

    — PHP Extensions:

    FSOCKOPEN: Your server supports fsockopen.
    cURL: Your server supports cURL.

    — FTS Settings->Global Options:

    Cache time: 10 Seconds (for testing only)

    — Active Plugins:

    1&1 WP Wizard: 2.0.1
    Akismet Anti-Spam: 4.0.3
    All-in-One Event Calendar by Time.ly: 2.5.31
    Anti-Malware Security and Brute-Force Firewall: 4.17.58
    Black Studio TinyMCE Widget: 2.6.2
    BuddyPress: 3.0.0
    Childify Me: 1.1.1
    Contact Form by BestWebSoft: 4.1.0
    Custom Facebook Feed: 2.6.1
    Custom Meta Widget: 1.5.1
    Ditty News Ticker: 2.1.16
    Easy FancyBox: 1.8.3
    Embed Any Document: 2.3.2
    Enhanced Media Library: 2.6.3
    Feed Them Social (Facebook, Instagram, Twitter, etc): 2.4.0
    FooBox Image Lightbox: 2.5.2
    FooGallery: 1.4.31
    Instagram Feed: 1.8.3
    Jetpack by WordPress.com: 6.1.1
    Members: 2.1.0
    Page Builder by SiteOrigin: 2.6.7
    Plugins Garbage Collector: 0.10.3
    SiteOrigin Widgets Bundle: 1.11.8
    TinyMCE Advanced: 4.7.11
    UpdraftPlus – Backup/Restore: 1.14.7
    WP-Sweep: 1.0.12
    WP Log Viewer: 1.2.1

    — Custom Token or Keys added to Options Pages
    — You must have a custom token to use the feeds

    Facebook App Token: Yes
    FB App ID for Like Button: No
    Twitter Consumer Key: No
    Twitter Secret: No
    Twitter Token: Yes
    Twitter Token Secret: Yes
    Pinterest Token: No
    Instagram: No
    YouTube: No

    — FaceBook & Twitter Date Format and Timezone

    Date Format: l, F jS, Y \a\t g:ia
    Timezone: Europe/Belfast

    — Fix Twitter Time:

    Fix: No

    — Disable Magnific CSS:

    Fix: No

    — Fix Internal Server Error:

    ### End System Info ###

    Just a quick note to say i have reset the cache time to the default it was set to 10 seconds for testing.

    Plugin Author slickremix

    (@slickremix)

    Perfect, now just wait like an hour or 2 and the feed should come back up. Having it set to one day is the best option and if you must have the posts show right away you can always manually delete the cache and you should be good.

    Spencer

    Cheers Spencer – i will check back later tonight and report back – thanks again

    Thats it working now thanks for the help didnt realise waiting would be the fix 🙂

    Plugin Author slickremix

    (@slickremix)

    Awesome glad to hear it’s working again. And yeah that’s a rule in facebook’s API, it’s roughly 200 API calls per hour, same with Instagram… so if it maxes out then it basically can take up to an hour or a little more to not be maxed out and allow access again. We are going to work on a solution soon here where instead of showing nothing on the page, if it hits the max API, that it at least shows whatever was loaded previously and to then check once access is allowed again to load newer items. Hope that makes sense.

    Spencer

    Cheers Spencer – good to know – thanks for the assistance

    Plugin Author slickremix

    (@slickremix)

    You got it!

    If you have a second and wouldn’t mind leaving a review for us, we would be very grateful.
    https://wordpress.org/support/view/plugin-reviews/feed-them-social

    Or if you have a facebook account and want to leave a review for us there, that would be awesome too.
    https://www.facebook.com/SlickRemix/reviews?ref=page_internal

    Be sure to follow us on Twitter for important updates @slickremix or https://twitter.com/slickremix

    And Done!!!

    Thanks again

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.